"NO STORAGE PRESENT" error using My Passport drive in NTFS format with WD TV

Hi all,

I just bought WD TV and a WD My passport Essential HD to go with it. I have heaps of media I cannot access because I get the “No media present” error when I connect the drive. It is formatted in NTFS as it was off the shelf.

USB sticks formatted as FAT 32 work fine. I am assuming it may be due to password protection these drives come with. Is there any way I can get around this? Should I just re-format drive to get rid of password stuff?


I have the same problem with a samsung hard disk drive (640Gb) it works perfectly on the PC fit fs NTFS but whn i plug it in the WD HD TV doesnt read anything as nothing plugged in…

when i reformat it as FAT32 it works… BUT I NEED NTFS… i have too manu hd files that are more than 4Gb…

Please Help me… I dont know if is the WD HD TV that doesnt read that HD or if is the Hard Disk that is not working good…

please help me too!

You are so right about that cant work but remember when you buy the device inside of box have user guide and there show you all passport drives need to connect in  back  of device via usb and all massive devices (portable 3.5) need to connect on side of device via usb.I have right now 7 terabyte(3.5 inch 3x 2tb wd +1tb wd on side connect and in back of device 2x 750 wd passport .they all work very good with out any problem but dont forget when you connect more  then two devices you need to use multi usb with adapter ,if you use direct connect  to  multi usb with out adapter will not work because the device cant gived to same energy to all hard disc. i hope this help samething

I have the same problem.  The first time and second time I used it worked fine.  I added more media files connected it and it wouldn’t recognise it.  I ran the diagnositcs and it showed the passport elite HD driver failed.  I purchased My Book Elite loaded the media files, plugged it in, nothing won’t recognise it. 

Can’t up grade the firmware either. 

I took a cheap USB device downloaded one movie on it connected it…I had no problem.   

I have a 1st generation WD TV with a WD Elements 640GB HDD.

I get the “NO STORAGE PRESENT” message when I reconnect the HDD after saving new files.

Try turning the WD TV off with the remote then on again with the HDD connected.

You may have to wait for a short while but it should then find the HDD.

It will then take a while to interrogate the media if there are a lot of files on the HDD.

At least that works for me.

Hope you sort it as this is a great little device.

Good luck.

Hey tom

Did u find a way to get around this problem coz i am having the same thing happen to me :frowning:

if u can email me back would be great cheers