No ssh access, no ftp out of the box product

Hi everyone,

im frustrated…

Have been trying to connect to ex2 using ssh/ftp for couple days now with no luck.

ssh is on at the back. connected to same wifi. I go to terminal, type ssh xxxx@192.168.0.x  - it gives me

ssh_exchange_identification: Connection closed by remote host

ftp - same story. on in the settings. on for every share. port 80 and 21 both are being forwarded to EX2. Yet, failing to connect outside home network.

While im on it - neither my dashboard is accessible over internet, so maybe thats a factor of some sort. (assuming it CAN be over quick view if port80 is forwarded?because i CAN open , but a lot of functions simply dont open - like transmission or P2P, so cant start torrents over internet)

Rebooted gazillion times - didnt help.

Any help would be appreciated.



Make sure that both services are properly enable trough the dashboard of the unit.

Please note that modifying the drive using SSH voids the warranty on the unit.

No, your dashboard being inaccessible from outside has nothing to do with these issues. To make your dashboard accessible, make sure you turn Dashboard Cloud Access setting to On. And since you already mentioned you’ve setup port forwarding for port 80 on your router that would suffice. Also, be aware that you are opening up access to the dashboard to the world, so be sure you have a strong enough password for admin acct. Once you turn this On, any web site you setup using Joomla or WordPress will also now be available from outside…and you’ll be able to fully realize the usefulness of those CMS apps (I personally prefer Joomla for it’s more wider and richer featureset than the less complex but easier to get used to WordPress if you’ve never used either one).

SSH access: Make sure you are using the username indicated in the help tooltip next to the SSH access setting in the dashboard. And be sure to be using the same password that you have set to when enabling SSH access.

FTP access: Some ISPs actually block port 21, so it may not be accessible at all on that port and in that case you’ll have to use a different port…the dasboard setting allows only two other alternate ports (2121 & 9921), but you can use almost any other port of your choice by overriding the setting manually from the config file stored in /usr/loca/config/config.xml if you ssh into the server (technically it is not the config file but backup of the config file that the server copies over to the actual config file at /etc/NAS_CFG/config.xml after a restart). But assuming that ISP port-blocking is not the case here, make sure you setup port forwarding on your router for the same passive port range that you’ve setup in the ftp settings in the dashboard, in addition to port 21. And make sure you are using Passive Connection in your ftp client. Passive connection is easiest for most folks unless you really want to complicate things and use active connection.