No signal when connecting WD TV live to new Onkyo Ht-s3500 Home Theater System

I have had my WD TV LIVE player for a while and I absolutely love it. I just bought an Onkyo HT-S3500 Home Theater System and when I have it connected through the receiver I am getting “NO SIGNAL” on my Tv. I have switched HDMI cables and switched input devices to no avail. When I switch a different component to the same HDMI input it works perfectly. When I hook the WD TV LIVE up directly to the tv I get no sound through the receiver but when I turn the receiver off I get sound through the tv. So basically all the components are working perfectly but I can’t figure out how to get my WD TV LIVE to output sound through the receiver. This is primarily the reason why I bought the Onkyo in the first place was so I would be able to use it with the WD TV LIVE. I love both products but I’ve spent all day trying to figure it out and it’s getting frustrating. When I called Onkyo they told me that since the Onkyo was working properly that I would have to call Western Digital. Western Digital told me basically the same thing but told me to call Samsung for some reason. I’m tired of getting the run around and would like a quick solution to the problem. Any help will be greatly appreciated!!! Thanks in advance for anyone wiling to take the time to help me out!!

so you are connecting the WD TV to TV via HDMI… What about the receiver?

What audio settings do you have on the WD TV when using the receiver?

When I have the WDTV Live connected through the receiver and then select the imput I have no signal at all. Like the receiver doesn’t even recognize the WDTV LIVE. I spoke with Onkyo Tech and they told me to hook the WDTV LIVE up directly to the tv and then run an optical cable from the WDTV LIVE to the receiver and change the audio ouiput on the receiver to optical for the device. So right now I have audio coming through the Receiver via optical but it is not HDMI like I would like as the receiver does not recognize the WDTV LIVE when I plug it into the receiver. Everything else works fine when plugged into the inputs on the receiver and are recognized and I have video and audio via HDMI, Playstation 3, Xbox 360, Cable box, just not the WDTV LIVE.

Dude what you mean is not " HDMI like "

Optical audio is the way to go when connecting to stereo receiver 

Wizer wrote:

Dude what you mean is not " HDMI like "


Optical audio is the way to go when connecting to stereo receiver 

I would disagree… HDMI is far superior to optical.  Optical is to be avoided at all costs if the receiver natively (and correctly) supports HDMI.

that would depend on the user or the user wishes to play on his player as to hdmi vs optical i have a link showing hdmi is way better (

ongandrw wrote:

that would depend on the user or the user wishes to play on his player as to hdmi vs optical i have a link showing hdmi is way better (

That link should read  

I have the same problem - with Onkyo RT680

When I unplug the WD TV Life (electric plug) and wait a few moment, and then restart the WD TV Life, I get a logo of WD on my screen. After waiting for 10 -20 minutes, the system sometimes connects, and then everything works fine until it is turned of again. I tried connecting it on different HDMI inputs on the OnkyoRT680, but it makes no difference. I thing the problem lies with incompatability issue between WD TV Life and the OnkyoRT680 system.

The WD TV Life connects perfectly when it is connected directly to a HDMI input on my TV (Sharp)

All other products connects perferctly to my OnkyoRT680 - on all the HDMI inputs. So seperately both the WD TV Life and the OnkyoRT680 works fine, but together there seems to be a incompatability issue.

If I solve the problem, I will post it on this bulletin.

Good luck!

I have a solution round this problem - it works for me.

  1. Turn WDTV  on and connect via HDMI directly to your TV (do not connect to amplifier)

  2. Find the file that you want to view - and start playing it.

  3. Pause file (with WDTV remote)

  4. Do not turn WDTV off, but disconnect HDMI cable that connects WDTV to your TV

  5.  Connect HDMI cable from WDTV to Onkyno amplifier - now it should play.

I think this is a connection problem with the Onkyno amplifier that does not recognize the signal from WDTV unless it is already streaming/playing a file.

Hope it works for all of you.

I will try to report this to Onkyo.

Even a better solution.

Onkyo amplifiers has trouble playing the WDTV menu when getting the signal via HDMI cable. However, you can play the WDTV menu directly to your TV via composite mode. So if you can get the file up and running via composite mode, then you can change to your Onkyo amplifier’s system. 

Here’s how:

  1. Connect WDTV DIRECTLY to  TV from DV out to component connection on TV (3 connectors)

  2. Connect WDTV to your Onkyo amplifier with HDMI. I have mine on HDMI4 input, but any available input will do.

  3. Power  WDTV on.

  4. Choose the input mode on you TV  as Composite. You should be able to view your WDTV menu now, and navigate to the file or video you want to view.

5 Once your file starts playing, press the pause button on your WDTV remote.

  1. Change the input mode on your TV to the HDMI that connects your Onkyo amplifier.

  2. Change the output mode with your Onkyo remote to the option that connects your WDTV.

Now you should be able to view the file on your TV via the Onkyo amplifier - just press play on your WDTV remote.

Doing it this way saves you the trouble of connecting/disconnecting the HDMI cable all the time.

Hope it helps you.

Hi there

I know this is a older topic, but thought it would be nice to post my  findings.

I had the same problem with my receiver, not a onkyo but a yamaha in my case, but the problem you discribe?

is just the same as mine.

here is what I did, and it helped for me…

connected my wdtv to my Tv with hdmi

went to my wdtv settings

went to  audio/video

set my regional tv standard from auto to PAL (in my case)

Changed my resolution settings to 720p 60hz

changed my color space and color mode

Connected my wdtv to receiver to tv

and my problem was fixed.

point is that it wil decrease video qaulity, but at least I got it to work.

hope this helps, if you didn’t allready found a better way.