No signal for HDMI? Composite only works with HDMI plugged in?


So ive had my WDTV Live Hub plugged into my TV via HDMI for about a  year now and i haven’t had any issues ever.

I brought my WDTV to my girlfriends house and plugged it into her TV via HDMI and there was no issues with playback.

I brought it home, and now HDMI output shows no signal. Doesn’t work. I figured there was something different about our 2 TV’s and somehow teh settings changed, so it wont work on mine but it should still work on hers.

Instead of going back to her place, i tried using Composite cables. There is a signal, BUT it’s very inconsistant. Black and white, static, image sliding from left to right fast enough so there is nothing visible on the screen except for shapes. 

Weird thing is, if i plug in the HDMI while on the Composite input, the signal fixes itself and everything is stable and in color. 

So HDMI doesnt work alone

Composite doesnt work alone

Composite and HDMI work for composite.


So i did a factory reset hoping that would fix something, and of course it didnt.

I’m trying a firmware update now (3.06.14. I was on 3.03.xx before) and hopefully that will fix something, but who knows.

Im out of ideas if this doesnt work. Anyone?

For the composite issue, it sounds like your device is set to PAL instead of NTSC or vice versa.

Power the box up and wait until the WD logo stops flashing.

Then hold the RESET button (on the bottom) for 10 seconds or more.

That will toggle the modes between NTSC / PAL.

As for the HDMI, it may be that the cable or connector was damaged when it was plugged our unplugged, but who knows…

Hmm, ok ill give that NTSC/PAL swap a shot. 

As for the HDMI being damage, I dont know. Im usually pretty careful with my electronics. It’s also blowing my mind that Composite doesnt work UNTIL i plug in the HDMI. Almost makes me think that the HDMI is still functional.

Im heading over to the girl’s tonight. Ill see if it works there. 

Alright, holding the reset button set it back to NTSC :smiley:


So composite works fine.

But composite **bleep** :frowning:

resolution is set to HDMI (Auto). It changes back to composite if i unplug the HDMI cable. So the HDMI should work fine. Any other ideas?

You could try a different HDMI cable plus a reset to factory defaults. Did it work at your girlfriends?

I tried a different HDMI cord and a different TV input.

No dice :frowning:

Didn’t get a chance to go by the girlfriends yet.


mazza2590 wrote:
Didn’t get a chance to go by the girlfriends yet.


I’m here now and I confirm that it does not work.

[Deleted] :frowning:

There is no sign of damage or anything.
I wonder if I’m still covered under warranty


**bleep**, out of warranty :frowning: