No share now from usb drive that was working fine before

Hi, I’e wasted hours on this so far, I’m totally at the end of my paitence with this…  let me explain.

I have a 500Gb WD (how ironic) my passport usb3.0 drive, formatted for mac HFS+j which contains my iTunes library.  It has been connected to the MyCloud EX2 since I’ve had it which is about 2 weeks.  I’ve ejected it many times to take with me and it’s always connected fine when I’m back.

However today, it connects fine, shows up in the ‘USB connected devices’ along with the size and free space.  But no share. nothing.  When connected directly to the mac the drive is fine, I’ve used disk utility to confirm the integrety of the drive.  zero problems there.  it’s been ejected properly EVERY time…

No matter what I do (reset the MyCloud to factory settings etc) it simply just does not provide the share to connect it over the network.  I’ve tried both usb ports and its the same.  I’ve confirmed both ports are working with another drive that does work and appears in the share (another WD drive as it happens)  So i can only conclude it is something in the software on the MyCloud itself.

How do I get it to completely (at system level) forget ALL drives I’ve ever connected to the usb so I can connect them again and get it working…  Without wiping out my timemachine backups.

Please help if you can.

Hello itsmedammit, welcome to the WD Community. Sorry to hear you’re having problems. Have you tried changing the Passport name? 

Hi jubel04,

thanks for your reply.  Yeah unfortunately I have tried that too but it made no difference because I cannot change the logical name of the disk only the partition name.  The EX uses the logical name to identfy the drive when it’s connected, it just point blank refuses to show the original share set-up for this disk.  Is there a way to remove any reference to this disk from the EX system so that when I connect it to the EX again it thinks it’s the first time the drive has been connected?

do you have a copy of the HDD, because i don’t see any other solution than formating the drive? I have seen this behavior on the forum and that’s why i was afraid to buy only one EX2 and have a backup to an external drive, because it’s not to be trusted. So i bought 2 EX2 and made a remote backup.

1 Like

Hi adicrst,

thanks for your suggestion.

I copied the contents of the USB drive to another via the mac and re-formatted the offending one.  The EX now recognises it and presents a share for it under the shares section. 

Having then set-up the share name, settings etc and copied the data back to the drive from the other one it is now back to how it was before the probelm occured. 

At least I can sort it out quite easily if it happens again.  Bit dissapointed that it happened in the first place though.


I am glad to see it worked.

I also hope that WD will fix this with firmware update and becomes more stable and reliable.