No se monta mi Disco duro externo WD elements de 1t en macbook

hola, consegui un disco duro de WD elements de 1 Tb y me llego hoy, el empaque estaba normal y todo pero cuando lo conecte a mi mac no me dejaba escribirle datos.
fuí a internet y dice que tenia que borrarlo y dejarlo en ExFat pero cuando lo hacia nada pasaba y me dice que error. intente todos los medios hasta restaurarla pero me llevo a que se desmontara el disco y ahora cada vez que lo conecto, no me aparece en el escritorio pero si en utilidad de discos pero no me deja montarla. llame al servicio de apple pero no me dio solucion.
AYUDA

hola, pudiste resolver el problema? me ocurrió lo mismo. saludos

Mira está fácil de reparar el problema, consigue un amigo con pc borra completamente la memoria y luego ya ponlo en ExFat desde la pc y ya quedó sin problemas en 5 minutos

y dice que tenia que borrarlo y dejarlo en ExFat pero cuando lo hacia nada pasaba y me dice que error. intente todos los medios hasta restaurarla pero me llevo a que se desmontara el disco y ahora cada vez que lo conecto, no me aparece en el escritorio pero si en utilidad de discos pero no me deja montarla. llame al servicio de apple pero no me dio solucion.
AYUDA
https://subwaysurfers.vip/ https://psiphon.vip/ https://hillclimbracing.vip/

Mira está fácil de reparar el problema, consigue un amigo con pc borra completamente la memoria y luego ya ponlo en ExFat desde la pc y ya quedó sin problemas en 5 minutos

Me a funcionado el HD durante 6 meses a la perfección y sin ningún problema, pero nunca logre resolver por que mi Macbook no pudo reconocerla