No response from the HDD at all

Hi, guys

So here is my problem:

I bought a WD 3TB external hard drive couple years ago. I am generally a Linux user, though a used NTFS on this HDD, and hadn’t had any prolems with it. Recently I tried to copy some files on it from a Windows machine and it gave me an error message (0x8007045d). I could not copy anything on it, but still could access all the files. I checked my Linux laptop once again, everything was still working fine. I tried to run a standard Windows disk error check, it said that it found errors and asked me to reboot the system. After the reboot I couldn’t acsess the drive, although WD showed up as an unkown device in the device manager. After that I tried to do the same thing in Linux, it recognized the device, I ran a quick GSmartControl on it and it stopped in the middle of the test. (i think I still have a log from it, doubt it will help though). I disconnected the device, took a break for dinner, came back and…

The drive now is not recognizable by any computer. If you plug the power cord in the light comes on and the cooler starts working, moreover it does so no matter if my USB is connected or not. If you do connect the USB, there is no reaction neither from computer nor the drive.

I know it sounds like a failure, but I’m very surprised it happened all of a sudden. As I said, it was working perfectly fine before with Linux.

Do I have any hope?

Thank You

The drive partition table could be corrupted.

This might happen when using the drive between two different platforms.

Try using a data recovery software and see if possible to retrieve the files.

1 Like

Thanks for the response.

I tried to run recovery software in Windows and Bios, but the drive just doesn’t get recognized.

In this situation it will be good to contact a data recovery company.

Take a look at the list bellow for more information: