No Remote mycloud access

I can access the my cloud remotley. When I look at settings & cloud access it says: “connection status: no internet access”. How can I change that?

That’s hard to answer.  

The error message is pretty explicit – for whatever reason, it cannot access the internet.  And without internet access, remote connectivity cannot work.

So, you’ll need to do some troubleshooting to find out why it’s not connected to the internet.

How is it connected to your home network?  

The mcloud device is connected directly to a router via network cable. How would I toubleshoot?

There might be some router settings that you can change to open a port. You would access your router via its web server. Do you know its IP address? Try http://IP/

There are some instructions on the WDS support pages for a few routers.

I thought I had mine set properly but it looks like I need to do some work when I’m with My Cloud.

The first thing would be to make sure you enable UPnP on your router.   If your router doesn’t support UPnP, then you’ll need to configure it all manually.

What OS are you on?