No remote access. Invalid request. (404)


I just purchased a 4TB WD MyCloud. When I get it I install it in my work place and everything works great. Few day later I bring it to my home and now I have a problem to get remote access to MyCloud. It’s impossible to get remote access through Android app (Nexus 7 2013 and Moto G 1st Gen - Invalid request. (404) or web browser also.

Everything is fine when I stay on my home network. PC works fine and also I can connect by mobile through SMB client (Solid Explorer). Also I saw one thing yet, that android app works well (on my WiFi network) when I turn off Cloud Access in WD MyCloud UI. When I bring my WD Mycloud to my home I made System Factory Restore (System Only).

I have Enable Auto Update (Firmware v04.01.02-417) and I reset all settings on android apps. I try reboot device many times. I have turned on UPnP on my router (Technicolor TG582n). Connection Status is Connected (Port forwarding connection established). It is possible to send Notifications Email so I think that NAS has internet connection. My UI connectivity settings are set to Auto. SSH id Off. FTP is Off. Network mode is DHCP. iTunes Server is Off. Time Machine is Off. Drive Sleep in On.

Please help me because my device i uuseless at this moment.

Hello K100Ramm, welcome to the WD Community. Have you tried to setup a new activation code? 

How to access files on a WD My Cloud, Mirror, EX2, or EX4 Personal Cloud drive using WD My Cloud Mobile App 

Yes, I tried this but it doesn’t help. I can pair my mobile devices with MyCloud but i can’t connect  :(

Have you tried toggling the remote access off (wait) then on at the settings? Also your router’s upnp actualy works? (the port opened by upnp e.g. 9080 and 9443 gets routed to your cloud ip) Check if you have other port forwardings that might overruled the upnp. Or better assign the ports manually on both router and cloud.

If those aren’t helping, I won’t explain this in details but this does help me sometimes after looking into the codes, try renaming your cloud at the settings.

1 Like

Thank you very very much. It helps and now everything works well even though there is write that: “Port forwarding failed to connect on port 9080 and port 9443.”

No problem glad it helps. Don’t worry about that error message, it will go away after awhile.