No Private Share Access on Win7

Hello everybody,

I’m currently facing a problem with my brand new MBLD 6TB.

As it seems, i can’t connect to my private share via Explorer or WD Link. The access prompt doesn’t swallow my access credentials. Neither Workgroupname\username nor \mybooklive\username work and i’ve checked & changed my username and password several times. Furthermore, the cmd net use list is empty, so there’s no conflict either.

Any advice from you guys? I would be pleased as **bleep**, since i don’t dare using my NAS without privacy, even in my home network.



/* edit:

h e l l    gets a bleep?! REALLY?!

Check the windows Password Vault and make sure there’s nothing there for the MBLD.

Thanks for your suggestion, but I dropped everything related with the MBLD and it didn’t work.

I’m fiddling with this issue for hours now… this isn’t the plug&play of Western Digital Products I’m used to.

/* edit

Ok, i finally got some news. It works with other user accounts than the admin account. But the latter still won’t be able to get access to any private folder (from the same computer), even though I’ve granted myself the respective rights. [Deleted[?

/* edit²

Please don’t get me wrong, i still like to have a proper solution. This has to be a bug, right?!

Same thing. I created a bunch of users so I need to setup my personal folders as only accessable by me and then I try to connect to my shares it requires password. OK I know the password, I enter it and then windows shows me that I got wrong credentials. I think it’s because it automaticly adds compuername as a part of the login before actual username. 


BTW everything works through the Web interface, because I procceed with authentification before it allows me to mount my share. So this is clearly a windows issue, just point us where we can fix this.

UPD. I created another user with the same access rights as admin anв it worked. But now I can’t connect to WD SmartWare with the same error, but now it adds HOME to the beginning of admin name.


My SMB configuration is

  load printers = no
  printing = bsd
  printcap name = /dev/null
  disable spoolss = yes
  log file = /var/log/samba/log.smbd
  max log size = 50
  dead time = 15
  security = user
  # auth methods = guest, sam_ignoredomain, winbind:ntdomain
  encrypt passwords = yes
  passdb backend = smbpasswd:/etc/samba/smbpasswd  
  create mask = 0775
  directory mask = 0775
  local master = yes
  domain master = no
  preferred master = auto
  os level = 5
  socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
  min receivefile size = 128k
  use sendfile = yes
  dns proxy = no
  idmap uid = 10000-65000
  idmap gid = 10000-65000
  dont descend = /proc,/dev,/etc
  admin users = victor-pc\victor, victor-pc\admin, home/admin
  null passwords = yes
  map to guest = bad user
  guest account = nobody
  unix extensions = no  
  acl check permissions = false
  max protocol = SMB2

Hi …

Did anyone find a solution for this ? I have the same problem. I can not access my Private folders … It keep asking for a Password and I have tried with no luck.

I’m accessing the files from the Explorer … The public folders works fine, but the private folders just wont work.

I have setup the users on the WEB interface and made a password. First time I try accessing it ask me for User and Password. I believe it it here I put in what I did setup up in the WEB interface. After I does this it come up with the same login as mrvic shows (In my case PER-PC/username) … Why ?

I’ve tried to setup my pc admin with same USER name and password as I use in the WD software with no luck …

HEEEEELP anyone :confounded:

Looking forward to your help



Click “Run…”

Enter CMD in the search box and wait until cmd.exe appears, and then RIGHT click it and select Run as Administrator.

Answer any prompts until the black CMD window appears.

In that window, enter the commands

net use * /delete


Now try connecting to your private share.

Hi TonyPh12345

No luck … :cry:

First I went to CMD. Runed it as a Admin. Entered the command net use * /delete. with this result :

Translated from danish : No post on the list.

After this I try to connect to my private share

and I get the first login screen. Here I put in my User and password from my WD User


When I press ok i get the following prompt for a second login


I know it is in Danish, but what password should i use here ??? I have tried same user password from the WD with no luck. And why is my PER-PC standing in front og my USER name ?

I’m getting a little bit frustrated … I thought it was plug and play :confounded: I has now used many hours.

I really hope someone outthere can help

Did you change the Workgroup name of the MBLD to “PER-PC”?

If not, try that.  It should match your PC, which is set to “PER-PC.”

I also have this issue, but I noticed it only started happening after the WD Smart Ware was updated. I tried uninstalling hoping it would fix but no luck. It does seem to work on another laptop with Win 8 on which I had never installed WD Smart Ware. Any tips? I tried the net use * /delete command but it doesn’t seem to help.

Thanks a lot in advance!

I had the same problem and this solution worked for me:

Apparently, if Public is mapped first or already mapped, Windows won’t allow any private drives to map. I disconnected Public (I did this by right-clicking and hitting Disconnect), and then I could map all privates, and then I could map the Public. I did not have to go through all the CMD stuff as noted above.