No playback of videos, but browsing still works


#1

Hi, My WDTV Live stopped playing videos about 2 hours ago, just after I had finished watching a video. Browsing still works fine, as does viewing photos, but no luck with video. The content is stored on a WD MyBookWorld NAS drive, which is connected to my router, which is in turn connected to the WDTV Live. Accessing the MyBookWorld from any of my computers (wirelessly) works fine, but not with the WDTV. I’ve tried resetting it, but nothing changes. According to the menu, I’ve got the most current firmware for WDTV. Any idea what’s going on? All I get is the spinner and eventually the screensaver. I usually use the network shares option, but in this case the result is the same whether I use media servers or network shares.


#2

When you say browsing still works do you mean you can see the videos okay but when you try and play them they don’t play, correct?

The first thing I’d try would be to reset the Live back to the factory defaults (there is a setting option to do that, or you can use the paperclip hard reset).  You will then need to reset up your network and shares (and stick to shares for the time being).


#3

Resetting via the menu did nothing, however via the button on the side it at least got to the point where for the first video I tried, the progress bar shows. Only play time is shown as 00.00.00 and the screen stays black. Every subsequent video only gets as far as the spinner again.

And yes, you understood the problem correctly.

Edit: I also tried streaming to the WDTV directly from my Mac, same results. The files play fine any other way though, and files encoded with the same settings played fine until today as well.


#4

Try the power plug thing – with the unit on, unplug the power and wait at least ten minutes before plugging it back in.

And also try playing at least one video locally (copied to a USB stick or some such) just to rule out the video (yeah, I know you said they played fine before but humor me :>).  We need to rule out the network as the issue.


#5

hmm… I unplugged the WDTV for about 20-30 mins. Seems to work again. What exactly does unplugging it this way do to it that it fixes somesthing?


#6

maybe cleaning the RAM, no power no Data stored there :slight_smile:


#7

okay, I turned it off after the test because I was watching a movie on my iMac. Trying it now, I get stuck with a black screen again. What gives?? Would downgrading the firmware help? (Although most of my video content is in AppleTV format and only with the current firmware can I fast forward and rewind, something I’d rather not give up on again)


#8

Nothing suggested so far works. I tried playing one of the videos from a USB drive, but that also didn’t work. As this seems to be a common problem, should I

a) return the device

b) wait for a firmware upgrade

c) downgrade the firmware and see if that fixes it?


#9

By “AppleTV format” do you mean they have .m4v extensions?

If so, renaming the extensions to .mp4 will restore FF/RW functionality on older firmware if that’s an avenue you wish to explore.


#10

Yeah, they are .m4v’s, encoded with Handbrake’s ATV preset. I’ll see if downgrading works

EDIT: As best as I can tell, downgrading to 1.01.24 fixed my problems.