No picture from WDTV Live Plus


#1

Just got my brand new WDTV Live Plus in the mail today.

I can’t get it to load anything past the initial WD boot screen.

If I pull the power plug and re-insert it, I am able to see the blue WD logo on HDMI, Component, and Composite, but after about 10 seconds, it disappears and the TV can not get a signal on any of those interfaces.

I have tried pressing the reset button for 10 seconds, and for 30 seconds, and nothing changed.

I tried downloading the beta firmware here:

http://download.wdc.com/wdtv/wdtvliveplus_1.03.43_B.zip

…and booted the WDTV with the USB stick in the side port, hoping for a “upgrade firmware” prompt, but I got nothing.

Any suggestions on what I should do?

Thanks,

-Wes


#2

Welcome to the forums.

First things first – do NOT have the HDMI interface plugged in while you are trying composite video.  Let’s stick with composite for now.

Secondly, you may have (by pressing the side button) turned it into a PAL display (or NTSC if you are in PAL country) on.  So do this – unplug the Live from power for at least 10 minutes.  Plug it back in (and without the HDMI cable in) plug it into composite into your TV.  Try it now.  If it doesn’t work, try holding down the side button for at least 30 seconds and do exactly the same thing.

If THAT doesn’t work, return the unti for a replacement.


#3

Mike,

Thanks for the reply.

So, left it unplugged overnight.  I unplugged everything except for the component connection and the Ethernet cable.

Plugged the power in and got the WD blue logo for 15 seconds, then no signal at all (not out of TV range, just no signal).

My Samsung LED DLP supports every resolution up to 1080p over component (really!), so if there were any signal being sent, it would have picked it up.

I held the reset button for 12 sec. and nothing happened.

Then I pulled the power, plugged it back in, and immediately held reset for 10 sec.  I saw the blue WD logo again for 15 seconds, then lost sync again.

At this point, I think I’ve tried every possible combination of holding reset and restarting things.

Is there any way to “force upgrade” the firmware, or to put the thing into recovery mode somehow?

Clearly video output ‘works’, it just won’t load the interface.  It sure would be nice to have console output at this point…

-Wes


#4

Its still better to try it with composite as recommended by Mike.


#5

OK, I’ll give it another go with composite.


#6

Alright, tried again with only composite and Ethernet plugged-in.  Held reset for 10 seconds, no dice.  Held for 30 seconds, no dice.

Unplugged and re-plugged while holding reset for 10 seconds, no luck either.

Same scenario, get the blue WD logo, then nothing.

Any last suggestions before I RMA this thing?

And should I RMA through WD or through the retailer?

-Wes


#7

Well, I *still* wouldn’t have the ethernet cable plugged in (only the composite output) but let’s stipulate for a moment it doesn’t make a difference.  Did you unplug the Live from power for at least 10 minutes after each reset, as I asked?

If so, it’s time for a new Timex (and I’d just return it where you bought it, assuming you’ve had it for less than a week or so).


#8

Tried with and without Ethernet.  No difference.

I can’t believe there’s no firmware recovery procedure on this thing…

Some combination of holding reset button while powering-on with USB stick/firmware plugged-in to the side.

Oh well.

-Wes


#9

What firmware do you need to recover?    If you weren’t able to successfully update, then there’s nothing to roll back to.


#10

As Tony said you only got the unit yesterday and it has never worked. You do realise I suppose that after the first logo the screen does go dead for about 30 seconds and then the WD logo comes back. I assume that you are waiting for some time after the first logo disappears. The reason composite is recommended for your problem is because there are problems with HDMI handshaking and that means that the second logo may not be seen. With composite this is not a problem. I also assume that you have the supplied WD composite lead plugged into the correct rear socket marked AV.

If nothing works then in the first instance you should try to get your supplier to take it back as it looks to be faulty.

Also for a general reset you need to press the side paperclip button for about 1 second with the unit switched on. You will know that something is happening as the unit will reboot.


#11

@TonyPh,

I didn’t mean “recover” so much as “re-flash”.  Sometimes re-flashing firmware can make a difference if the previous image is corrupted somehow.  I haven’t done anything firmware-wise to this unit yet, though.  I just got it.

I was hoping that there was some way to re-flash with the new Beta firmware from a USB stick by some method of holding the reset button and saying the magic incantation.

@RichUK,

Thanks for explaining about the reasoning behind using composite instead of HDMI. 

I hate HDMI because of the principle of DRM. The content industry forced HDMI down everyone’s throat to protect their product when component is a perfectly acceptable medium for transmitting HD images, even up to 1080p.  Plus, you have handshaking problems like the one you mentioned.

I always use YPbPr when I can.

I actually had no idea what happens after the initial WD screen goes away, because I’ve never seen it :frowning:

I have left it on for quite a while, though, with no results.


#12

The WDTV Live’s have a firmware integrity check on boot.   If it’s corrupt, you get a screen that walks you through the repair process.   I presume, since you’re not seeing that, that your firmware is fine.

If you’re not getting video out the composite, your unit is dead.


#13

I guess it’s dead then.

I do get the initial logo on composite, component, and HDMI.

Anyway, I think I’ve done my due diligence.  Most customers would have sent it back immediately.

Thanks for all the replies.

-Wes


#14

I bought this yesterday, and got home and set it up. everything looked fine. i was prompted for a firmware update, and did that. after it said ‘firmware is good and restarting’ or whatever the wd logo come on for a few seconds and now the screen is all garbled. tried composite vs component. and i was able to see there was still a firmware update. did that (and it did default me to PAL for some odd reason) fixed that. then i got picture after the update. went into the menu and changed to component and now it works like a charm thanks for the help. :slight_smile:


#15

For the record, I had exactly the same problem with my WDTV Live HD, I got the logo on startup and then I get a message on my Samsung TV stating “Mode not supported”, this was using HDMI.  Following the advice on this thread I switched to composite and it worked fine. 

Curiously, when I swapped the HDMI cable between the WDTV Live and my current FreeSat box then HDMI worked fine on my WDTV Live (and my FreeSat box wasn’t as fussy about the HDMI cable as the previously non-working cable in the WDTV Live works fine in my FreeSat box.), I thought that cable quality didn’t matter so much with HDMI as it was digital, it either worked or it didn’t but this would appear to not be the case as the WDTV Live certainly cares about the standard of the HDMI cable.  All up and running now though.  Out of the box my WD TV Live had firmware v1.02.21, I’ve just updated it to the latest v1.04.22V but still no joy with my cable so I’ll now leave it in the FreeSat box as it doesn’t care and I can’t see any loss of picture quality.