No output at all, solved only by unplugging power


#1

I have the 1st generation WD Media player – the WDAVN00, latest firmware (1.03).  I use the HDMI connection and attach a Passport drive to the USB connector.  It is a great unit except for one recurring problem.  Often, when turning the unit on, there is no output at all.  The TV just displays “no signal.”  I can turn the unit off and on several times and get no change.  The first time this happened, I thought the unit had died.  But then I tried unplugging the power supply, waiting a few seconds, and plugging it back in.  Ta-da!  It works.  

This started just a few months after I bought the unit and continues to the present.  It happens fairly often, and I sometimes have to do the unplug/replug thing more than once to get it working.  One thing I’ve noticed is that this seems to happen after I’ve disconnected the Passport drive, in order to put some media on it, and then reconnect the drive.  

It really drives me crazy because this is a terrific machine except for this one little flaw.  Sometimes I just know I’m going to have to spend 5 or 10 minutes standing in front of the TV playing with it before I can watch anything.

Do others have this problem?  Any idea what causes it or what could be done about it? 

Thanks, -abs


#2

Have you tried ‘wiggling’ the HDMI cable?  Or even pulling it out of the TV and re-inserting.

Some HDMI ports are known to be too loose to grip the cable fully, especially if the HDMI cable is heavy.