No option to enter activation code

So I installed WD 2GO on my iPad (3rd gen if it matters) and under Welcome I tap Connect Now.  This gives me the options to choose MyBook Live but when I do it doesn’t ask me for an activation code, it just says Cannot Connect to Device.  My PC is seemingly working fine with MyBook… And my Android phone gives me the option to add my activation code.  Any help would be greatly appreciated.  Thanks.

Try uninstalling and re-installing the app.

Which version of WD 2go did you install?   

Thanks for the responses.  Just uninstalled and reinstalled and still the same problem.  The version I installed is 2.0.1.  Maybe I’ll try the WD 2go Pro???  

You can try it, of course, but that’s the older version…  So when you first ran WD 2go, did it immediately lits your drive under CONNECT NOW or did you use the ADD button?   If you’re at home, when you press the ADD button, it doesn’t need the code, it directly logs in with password.

No, there was no option to add.  Only Connect Now and Demo Drive, then when I went into Connect Now it listed MyBook, followed by Dropbox and another MyBook option…I can’t remember which one but it wasn’t one that I had connected.  When I tapped on MyBook it just saysa cannot connect to device.  Now I did try the Pro version last night and it at least gave me an option to enter a PIN.  I didn’t go any further though, didn’t have time to get on the PC to generate the PIN.  But, I’d like to get the newer version working and of course I just have that “need” to figure it out…

Ok, dumb question: is the firmware on your MBL up-to-date?

Does it list your MBL under “Found in Network” on that first screen?

Have you tried the Add Manually option?

Great question actually.  I haven’t updated the firmware… however, as it turns out this being a new drive just bought this week it is already up to date.  I might have bigger issues though.  It was the first time I had gone into the dashboard and I kept running into errors.  I sent off this question to support…

I went into the dashboard but everything I try to do… set up security, enable remote access, add a mobile device etc. I keep getting errors, specifically 30500 and 31550 both internal server errors and also 31505 - The device could not be updated due to a communication or internal software error. 

Any suggestions?  Once again, thanks for your help.

Try updating the firmware manually,

Make sure you follow the instructions for which version you currently have installed.

I’ll try to get a chance tomorrow.  Just to be clear though, even though I’m already running current firmware I should manually update… Or reinstall the the same version firmware?

Sorry, I didn’t catjch that.   I’m surprised a new box has version 2 on it, though…