No Optical Audio on WD Hub. Works fine of WD TV Live


No Optical Audio on WD Hub., however works fine of WD TV Live when set to digital. Have tried all audio settings on the WD Hub. Note HDMI audio works to my TV, but no Optical, despite it working under the digital setting on the WD TV Live to my amps optical in… Is this a bug ???

Mine is working perfectly.

Have you tried to play something like a normal MP3 file? I ask this because I read that the high definition audio in some movies have a very high bitrate, that can be played over HDMI but not over an optical link.

If this is not working, maybe your device is faulty. Check if a red light shines in the optical socket on your Hub.

If it’s not, then your optical output is dead.

others have this problem? 
If true it seems a big bug that makes the downmix the HD audio formats in

PCM 5.1

Hi, thanks for the tips. Yes  tried MP3’s  with no luck at all. The crazy thing is my WD TV Live works perfectly ! Perhaps a faulty optical output on my Hub ?, cheers

Also, the optical red light is shining…

…yes, as I posted earlier today - 4/10/11, I’m having a similar optical audio loss on the Hub!

Apparently, either no one else (except in this thread) is having the problem and WD support has not deemed it necessary to respond.

Hold on a sec.   

If you set it to DIGITAL and it works, then obviously you need to set it to DIGITAL.



Pls clarify! What do you mean specifically and how does it apply to the Hub?  Thx.

Sorry, I was referring to the first post where the OP said it works fine on his LIVE if digital.   Wasn’t paying attention that we’re talking about the Hub.


I guess the crux of the matter is to make sure you set the hub’s AUDIO to DIGITAL OPTICAL, and make sure your optical cable is good.

Don’t use the presence of a red light to judge it as good…  Try another device that has a digital output like a DVD or CD player.


…appreciate your prompt reply! 

Hub is set for opt-dig-out and has worked for several months w/o/ problem (as related in my earlier post .) Cable was checked (works with another device) but swapped in another known good-one and problem remains. 

Thanks anyway!


I also have the problem that no stereo-encoded files will play any longer via optical output. Only via ordinary stereo (analogue) connection. WD support simply told me to downgrade to 1.04.17 to be able to listen to these files (MP3s, YouTube etc.) via optical (TOSLink) output again. This fixed it, but it’s not a solution as I want to make use of new features and it would be highly inconvenient to connect the WDTV through analogue and optical connectors and then have to switch around on the receiver depending on the media played.

As this bug is not fixed in 1.05.04 now, it would be great if everyone affected could bring up the issue with WD regularly.

P.S.: The only thing strange to me is the different problems that people are reporting: With some, it seems not to be a problem, whereas with others (including me) only a firmware downgrade works. Can those of you who got it working maybe post your configuration?


Im guessing its just typos with the firmware versions as none of them are WDTV Hub ones.

Yeah Ive always been fine, went from the WDTV Gen 1 to the Hub.

All firmwares, optical out to an old SONY DTS Amp setup.

I would say it has to be something specific to your Audio setup, but after reading and answering a few threads, even people with the same hub as me can’t play video files and stuff after or before doing firmware upgrades, so nothing surprises me at the moment.

Just for the record, mine is a WDTV Live, not a hub, but it seems to be the same problem. I also have an old Yamaha 5.1 receiver. But I think it has to do with the firmware as the TOSLink cable shows output (red light coming out of the cable’s end) and 5.1 encoded files do produce sound. Thus, they seem to have dropped the stereo-downmix via TOSLink. Not nice and in my opinion impractical, as most streaming stuff is still encoded in good ol’ stereo.

So why did you type Hub ?

All works fine on the Hub…Get one :slight_smile: