No Network Shares


#1

I have “Win XP Media Center” and I shared my folders over the network. I can access them from other computers on the network but not able to see them on my WD TV Live - Network Shares, which is a part the same network.

Any Idea about this?

-DR


#2

I struggled to stream from my Vista PC, could not get anything to work via Media Share or Network Share, I copied my movies into the Public folder and streamed perfectly via Network Share.


#3

I have nearly the same problem. But i use Linux together with Samba as file share service (same like with Mac OS X and Samba), the protocol (smb/cifs) is the same. In my case i select the Network Share Icon (video, music, pictures) and press the OK-Button on the remote control and nothing happens. Normaly i would expect a next dialogue window to enter the IP-adress of the server/computer, the network share name, username and password to create a profile on the WDTV Live for this share. But like described above, nothing happens. My WDTV Live is in the same LAN segment/environment like the server and i can reach the server from any PC but not from the WDTV Live. Or has anybody more experiences to describe how the WDTV Live work to reach network shares?

Thanks

Oelauge


#4

what do you mean by “Public Folders”. Were they on the same computer and same network?

-DR


#5

Windows Vista tree:

My Computer

Desktop

   “Your user name”

    Public

Computer

    “Followed by list of drives”

XP is completely different.


#6

I had no problem accessing my iMac  with WDTV Live for about a month…then suddenly all I get is “there is no media in the current folder”.  I started a service ticket but no reply so far.


#7

Got the same problem

Going to enter Network Share, OK and nothing.

Worked yesterday. Seen alot of people having this problem that it works sometimes…but should we be restarting the device 20 times to see a movie?


#8

Sometimes WDTV Live can take up to 10 minutes to find your shares.

Also check your workgroup name.   Use WORKGROUP  as the default for all connected pc’s on your network, yep WDTV Live is not that smart when it comes to network support


#9

This appears to be a Samba issue as one day everyting works fine for a while, then the next day it can’t see the shares anymore.  Power off, power on and 15mins l8r whoops the shares reappear.  How annoying is that…We’re talking basic functionality here…


#10

Quote: How annoying is that…We’re talking basic functionality here…

Is it really supposed to be this bad? Thought that was only in the 90s :frowning:


#11

After continual investigation it looks like  in Vista you need to specify which devices/computers on your network can access your shares via “media sharing, which must be on” located in the network properties within Vista otherwise the broadcast for shared resources/browser services in Vista appears intermittent.

It used to be so simple to share folders/files via XP however microsoft decided to make things more interesting.  I guess this allows you to be more granular in terms of which machines on your network can access which  shared resources. In otherwords not all computers can necessarily see all the same shared folders on your pc as was the case in XP.

I also created a local account in Vista and assigned permission to the account for folders I wanted to share.  The account/credentials are then configured passed via the WD Live.  There does not appear to be anywhere on the WD Live to specify a workgroup name.

Hope this helps.  So far my network shares show up consistently when browsing the network for shared folders from the WD Live.  Previously “media sharing” in the network properties was turned off perhaps explaining why the WD Live could not see network shares on my lan/vista machine consistently.

timpa82 wrote:

Quote: How annoying is that…We’re talking basic functionality here…

 

Is it really supposed to be this bad? Thought that was only in the 90s :


#12

Thanks but unfortunately it doesn’t.

Using Ubuntu.

I can view the folders on my windows computer.

Tried so many things, and restarted the WD TV Live unit at least 30 times, and waited about 10 minutes each time.

No luck :frowning: “Cant connect to the network” or something it says first time i try it, after that it says nothing.

Youtube and things like that works, so its not the cable or something like that.


#13

Ubuntu may have a similar approach to sharing folders with certain machines however I was referring specifically to windows vista.  Not sure how Ubuntu must be configured to broadcast it’s shares on the network to either all machines or specific machines.  It appears Vista can be configured to broadcast it’s shares to specific machines on the network. 

It would be beneficial to hear from someone who really understands how Ubuntu/Vista is supposed to be configured as a server.

I checked once more tonight after not accessing my share in 24hrs and my shares are showing up so I “believe” Vista may require the additional configuration as mentioned in my previous post.


#14

I got it working first time i tried it, without any special this or special that.

Just shared the folder (also activated guests) and tada, it worked.

Just not worked since. Heard someone said there is a new firmware out, will try that one.

Btw I downloaded 1.01.00 firmware, but how do I use it?

I put it on my USB stick and the WD TV can find it, but the files are called wdtvlive.bin, wdtvlive.fff and wdtvlive.ver.

Don’t know howto install it.

Edit: 1.01.77 wasn’t available for me (Europe - Sweden). Using 1.01.11.


#15

I just picked up this unit and originally had issues with my XP box not being listed under network shares until I turned SIMPLE FILE SHARING on.

Everything worked well last night until this morning when I tried to watch a movie. The only network share that would appear was my Ubuntu laptop.

After much frustration and searching online, I left the WD TV Live on the Network Share menu icon and a few minutes later, my XP shares appeared in the list.

I have a 1TB USB drive shared on one of the 2 XP computers on my network that I stream from. The only thing I can think of is this unit MAY be trying to cache all the folder names before displaying the list.

I’ve powered the box on and off a few times and have managed to have the list appear after waiting a few minutes. Frustrating to say the least. Once the shares are listed, I’m able to stream my media just fine.

I may end up switching over to the WDLXTV homebrew or setup an NFS server on my XP boxes seeing how my Linux laptop easily connects to the WD LIVE.

I’ll post my findings with the NFS server when I get a chance.