No Network device were discovered

MyBook World II on windows 7 64 bit

Short version: backup drive not found anymore… wd discovery cannot find it.

Long version:

Recently my backup stopped to work.
I checked and found that the backup device was not found by wd discovery.
I checked (router log file) and I noticed that the IP address had been renewed and changed to another number. I started having problems with the backup that day.

I assigned the same IP address as before but it still doesn’t work.

I powered off the disk (power button), unplugged the power cable and the network cable and after a minute I plugged the network cable and the power cable.
Power is back, I can see in my router that the drive was assigned the good IP Address and I can ping that address with success.

WD discovery still can’t find the drive.
Nothing has changed in the environment… no patch, no update.
My firewall is currently down and i’m out of options…

I can’t see the drive anymore in the Network option in windows Explorer… All I see is my computer, my printer and my router.

Formatting the drive is not an option.

Is there anything I can do to get my data back?

If you can ping the drive then you should try mapping the drive.

You can also connect the drive directly to the computer and access the files that way.

I cannot map the drive. windows cannot find it…

I tried using the device name that I set up  initially. I also tried using the IP Address.

Both ways gives the same error from windows.

Connecting the drive directly?

There’s a usb slot but I think that cannot be used to connect the disks because it is used to add another disk.

Using the network cable? Connected directly to the laptop?

I plugged it in but I can’t see my data… Is there anything I have to do to make this work?