No more shares after OS5 upgrade

My Cloud Mirror Gen 2

Updated to 2.40.157. Got the email that the firmware was successfully installed.

On subsequent reboot the dashboard reported OS5 upgrade is available so I clicked to update.

On the next reboot the dashboard prompted me to update my passwords, and also to update my MyCloud passwords. Then I received the “unable to connect to the firmware update server” error".

now the Dashboard shows

click on Diagnostics and it shows:

The storage tab shows:

My shares were initially showing after the 2.40.157 update and they were initially showing after the OS5 update. But now I only get connection errors and the Dashboard is showing 0.00MB free.

What should I do now?

@justplainlawr Please contact support and attached your system logs.

@justplainlawr Did you get support from WD? Were you able to fix the problem? I have the exact same issue as you, but with a My Cloud EX2 Ultra. I updated My Cloud OS 5 two days ago and I haven’t been able to find a solution in the internet. I already filed a ticket and I got the confirmation email from WD Customer Support, that’s it. My device is still useless. I haven’t done anything yet because I’m afraid of loosing my data.
Please if you already know how to fix this share the knowledge. I would appreciate it a lot.

Yes I heard back from tech support. They had me send my config files to engineering to figure it out.

The source of my problems is OS5 does not support any drives larger than 8TB. I have 2 x 10TB drives - these were recognized in OS3 but are no longer supported on OS5. Their reasoning is that the largest MyCloud Mirror SKU they sell is 2 x 8TB and they don’t need to support drives larger than that.

Any NAS solution on the market should allow for user-upgradability. I could write more about how shortsighted this seems, but yeah this is as bad as it sounds.

OS5 only supports up to 2 x 8TB. Proceeding with the firmware upgrade is catastrophic. Perhaps there should be a check by the firmware updater that verifies that the drives will work in OS5 before proceeding but what do I know.

Upgrading the drives on a NAS doesn’t seem like a wild expectation from a user’s perspective. Locking the user in to storage sizes that WD deems acceptable (ie: the original storage capacity)… I’m not sure what they expect users like me to do - go buy 2 x 8TB drives so I can downgrade my storage capacity? I do not find this acceptable.

Tech support proposed to ship my MyCloudMirror back to them and they would ship it back to me with OS3 installed. That way it would again support my 10TB drives. It was a generous offer, especially being about a year outside my warranty period. You might even say this is the right thing to do, but really it’s a situation created by WD.

So I bought a Synology NAS, and I’m enjoying that way more than I ever did the MyCloudMirror. I’m moving on from WD.

Needless to say the data that was on my drives was not readable on my new Synology NAS. I’m sure I could have hacked my way through command lines to make it work, but fortunately I had a sort-of recent backup. Always have a backup.

If I had taken WD up on their offer for the OS3 replacement, would I have been able to plug my drives in there and get access to the data on my drives? I never asked tech support because I was still beyond livid that their OS5 upgrade had essentially bricked my NAS in its current configuration. Unless I went out and bought smaller drives 8TB drives. Ridiculous.

Wish you luck. Tech support takes about 1 day to send out 1 reply (I’m sure they are also stretched thin due to the pandemic). Perhaps there is hope if you exported your OS3 config before you did the OS5 upgrade. Maybe the OS5 updater automatically makes a backup of the OS3 config. Probably not since there is no downgrade path once have OS5.

What’s worse is why WD allowed users with this configuration to proceed with installation if they knew upgrade was a one-way street and storage won’t work post upgrade. Nothing is more important than data for NAS and WD’s attitude here is horrible, go ahead and buy a new EX2 ultra if you want your data back, are you kidding me?

I still believe WD’s engineers tried to overhaul from a security standpoint with all the right intentions but bean-counters forced them to release too early and with far too many compromises and the team has since then tried to catch up. I don’t have a Synology box to test but found Virtual DSM to be generations ahead of OS3/OS5. Since my device is running out of space and I need to get a new NAS soon, what would you suggest?


This is completely inane.
I perhaps could excuse this in an initial release. . . .but now that they see the issue out there. . . . it should have been fixed in the next firmware release. You know this is a simple variable change in
one line of code.

HOWEVER: More to the point - - - - -from what I am reading about indexing. . . . I think the MyCloud Mirrors just don’t have the horsepower/Ram to run OS/5. Which is why people take WEEKS to complete indexing. Imagine if the Mirror had larger drives. . . Fundamentally, I believe the Mirrors should have been left off the upgrade list.

(Let’s not talk about transcoding on the PR units)

I concur with this sentiment.

I strongly suspect that someone spend a day or two created a powerpoint for a meeting with execs. . Then some poor schlub wrote afunctional spec based upon that powerpoint.
Once that functional spec was written. . . .nobody had the money/courage/foresight to make any changes to that that functional spec… . .

. . . .you just KNOW that some of these issues with indexing and the Cloud apps must to have been raised during alpha and beta testing. But because the problems were “functional” and not “bugs”; nobody was authorized to spend programming hours to fix it.

I can’t claim to know. . .but I would wager that this is how it happened.
I have seen this play out in industrial settings with programming of equipment control systems. It is quite nasty; especially if the programming is subcontracted.

I suspect that the only reason we are seeing the recent firmware releases is because of the sheer magnitude of the userbase backlash. The early firmware release notes had no indications that anything was wrong with functionality. . .now at least I think WD is admitting to a problem.

I still think that the reason we aren’t seeing any backlash over the web/phone apps is that nobody is using them. I have not touched them in a few weeks. . . I probably should amuse myself and see if anything changed.

My background is not programming, but rather being the poor schlub who has to make the blasted equipment work.

Nothing more fun that rewritting functional specs I had little to do with, for a programmer, on the fly, and testing the results live-in-the-field.

Well. . . reporting the entire thing to Executive management has it’s moments as well. Fortunately. . . if I do my job correctly, I don’t have to write incident reports or lead accident investigations.

You guys bring up good points, I wonder if WD internally views this OS5 transition as a “success” in moving their products forward while achieving an acceptable level of customer service failure.

I wonder if they know if the people in charge know they are turning their back on customers.

But as a casualty of this OS5 transition, from my perspective there is no way this is a success.

% adoption by user base. (probably moderately high - - -BIG WIN)
Sales figures (probably driven by sales. . . a bit too soon to tell, right?)

Support calls? (not sure which way this will go - - - they have to figure SOME increase in support just because “change”)

I wonder if they have actual “usage statistics” for the web apps. Be really curious what that looks like. I hear no discussion about the apps in the forums. . . . . which tells me that very few people use them. I don’t for a number of non-WD related reasons.

So. . .given the recent responses from WD staff; which acknowledge a few issues; and the semi-weekly Firmware updates. . . . I suspect they are aware they have issues. Certainly; in my several years on these forums. . .I never heard so many “synology” references.

I don’t think they were offering to downgrade mine, but to swap it for a replacement.

Thanks for the update. I just saw the detailed instructions posted here: Volume failure after upgrading My Cloud Mirror 2 to OS5 - #18 by winnd4spd