No more audio with any movie or mp3


my wd tv hd (gen1 firmware 1.02.07, never upgraded by choice) does no more play any audio neither via hdmi nor via optical cable.

I tried to change resolution, change between stereo and digital, tried to reset… but nothing happens.

I tried also to reset to factory settings via menu, not via external button.

i tried also deleting .wdtv directory.

Can you help me?

A falmily crisys is ongoing… my daughter cannot watch her movies…

Thank you in advance

It sounds like the header compression issue.

First unplug your WDTV for 10 minutes or so (perhaps longer).

Then, when you plug it back in, press the paperclip reset button on the side.

While it’s unplugged, download:

and then run MKVFix to automatically scan your media.

I know MKVfix works with v4.3.0 – it requires it… but I believe there are issues if you try to use v4.5 and v4.6, so stick with v4.3.0 to be safe.

thanks, this is the last possibility that i will try this evening (my time, italy).

any way, it would be a strange cause beacuse we did not play any strange file, neither avi nor mkv.

is ther any other possible cause?

Well, if _ none _ of your files are .mkv, then that fix won’t help you.

It’s just that when you play a bad .mkv file, the WDTV tends to stay stuck for a long time, and that sounded like what was happening.

I’d do the resets I suggested and then switch audio back to “Digital”, and not bother about MKVFix and MKVToolnix, and see if that gets you back up and running.

yes, of corse I have some mkv in my hard disk, not so many.

I had no problems untill now.

i recently added some one new, but i have not played them yet on WDHDTV, could it be the case?

the paperclip reset did not help.

i 've discovered that it could an hardware problem.

f i connect the stereo audio ext to my amplifier the audio is present.

Can it be an hardware failure of digital audio out?

audio is not available via HDMI and optical exit.