No Media Files in Dashboard

I am completely baffled by not seeing any Media Library files on the Dashboard that I have added through NAS as a network share in the media library manager. I have tried several different ways to see the files without success. These files are readily seen when I select the network share as a content source through the Media browser links on the Homepage. Also, I can see files that have been added through a USB device.

In the process of troubleshooting the problem I cleared the media library, added a folder containing only 10 audio files (.wma), watched the compile process occur, turned on the auto meta-data option, restarted the device, and still there are no files listed in the Dashboard. The .wd_tv folder is created on the NAS and contains 4 files.

I have also reverted from firmware version 2.02.32 to 2.01.86 since I had read about problems some were having with the player not recognizing added files after upgrading.

Is there something else that I am missing? The NAS device is a 6 TB WD Cloud, but I experienced the same problem with an old Iomega NAS, which I thought was due to this particular HD, but now it appears that there is something else causing the problem.

Hi, have you tried removing the .wd_tv folder from the NAS and let the media player create it again? I have to have a similar issue with my media player and a USB and this helped out for me.

Thanks for the suggestion. I think that I solved the problem by adding the NAS folders as NFS (Linux) shares rather than Windows shares. The files rapidly appeared in the Dashboard as they were compiled and everything seems to be functioning properly now. It’s quite interesting that nothing I can find in either the WD TV or the WD My Cloud documentation indicates that NAS shares should be accessed in this manner. I presume that when I access these files through my PC that it is doing so as Windows shares.