No longer appears on the network

My device stopped appearing as a network device in Finder (Mac), but I could still get to the admin interface. It fails the full test and offers to let me either send a report or save it to the disk. I tried to send it but it is now just stuck saying ‘Updating…’. I tried to save it but I have no way of accessing the disk to retrive it.


I recommend you contact support directly for assistance with this issue.

Personal Cloud Support

I’ve experienced the same, and the only solution that has worked for me is to manually unplug the device and then plug it in again after about 2 minutes.  I know it is not the best practice, but that is the only thing that has worked for me to restore proper connectivity.

I have this exact issue. I would be very grateful if you could post up your resolution.

a “system-only” reset did the trick for me.

My WD My Cloud no longer appears in my Network.  When I try to access My Cloud 3tb using the IPddress I get the M Cloud login page but cannot login when I enter the password.

what do I need to do?  Can I save the files I had stored on My Cloud?

My email is [Deleted - Privacy]

A reset worked for me. The 40-second kind when you switch on. 

Check the WdMyCloud manual for full instructions on how to do a reset.

When you reset your WDMyCloud, was there any issues with the existing database that is in the drive?



The 40s reset is the same as the system only restore. It does leave the content intact. You have however to recreate your users access rights. You will be left with only the default admin user with a blank password.