No longer able to mount NFS since 2.10.09 firmware install


I updated my firmware last week, and since then I am unable to mount the share on my linux boxes.  The errors are as follows:

On the Linux side, the error message is:
mount.nfs: access denied by server while mounting mybooklive:/DataVolume/shares/pete

on the mybooklive:

Nov 23 12:43:19 mybooklive kernel: svc:, port=1017: unknown version (4 for prog 100003, nfsd)

Looking on the web there are a number of references to this issue on generic linux boxes running 2.6.32 linux, but I can’t find any specific issue on the mybooklive.  Anyone got any ideas?


I have looked everywhere for something a least bit related to this issue and the My Book Live and nothing, why don’t you try WD Tech support?

It’s not the MBL.  I have the same version, and it doesn’t support NFS v.4 yet.

From your Linux box, do an rpcinfo to get the versions that are supported:

root@stump:/var/log# rpcinfo -p mybooklive program vers proto port 100000 2 tcp 111 portmapper 100000 2 udp 111 portmapper 100024 1 udp 52472 status 100024 1 tcp 60170 status 100021 1 udp 42880 nlockmgr 100021 3 udp 42880 nlockmgr 100021 4 udp 42880 nlockmgr 100021 1 tcp 44831 nlockmgr 100021 3 tcp 44831 nlockmgr 100021 4 tcp 44831 nlockmgr 100003 2 tcp 2049 nfs 100003 3 tcp 2049 nfs 100003 2 udp 2049 nfs 100003 3 udp 2049 nfs 100005 1 udp 47191 mountd 100005 1 tcp 51539 mountd 100005 2 udp 47191 mountd 100005 2 tcp 51539 mountd 100005 3 udp 47191 mountd 100005 3 tcp 51539 mountd

 As you can see, the MBL supports versions 2 and 3 of NFS.  So on your Linux box, you need to specify version 3 on your mount, either in your autmount entry, or in your fstab if you’re doing it that way.  There’s  a mount option for that.

I’m using the automounter, with the /net entry in the /etc/auto.master, which in turn calls the /etc/ script to produce the automount map automatically.  You can run this to get the map, and as you can see, I’m specifying nfs, not nfs4.  This is configurable within the script.

root@stump:/etc# ./ mybooklive-fstype=nfs,hard,intr,nodev,nosuid \	/nfs mybooklive:/nfs

I’m guessing that you updated your Linux boxes recently?


Thanks mstargard that fixed it.  I had tried mounting the filesystem as nfs3 before, and that hadn’t worked although the manual implied that it should.  Setting the fstab entry to vers=3 did the trick and it now mounts.

I think I had the perfect storm of updates on Ubuntu and the Mybooklive to break the functionality, as the entries in /etc/exports had also been deleted.

For the record, I did contact WD tech support, but there answer was “I truly apologize for this inconvenient, but unfortunately this drive was designed to work on windows and Mac not on any kind of Linux box, because of this we never tested the drive or the updates on Linux, and this is why we are unable to give support to this particular OS.”  Which is rather disappointing.