No lights at all, Only sound

#1

My device has suddenly stopped working, I can’t access it, can’t find it on the server, no lights whatsoever, but I can hear the fan and some sounds when power is connected. Help please! :’(

#2

What specific My Cloud device do you have? The single bay/single drive My Cloud units (image below) do not have a fan. It has LED lights both on the front and on the networking port on the back of the device. When receiving power the LED ports on the networking port will be illuminated when the My Cloud is properly connected to the local network router (or network switch).

#3

Yes this one exactly, I’m not sure its the fan or not but I can hear something functioning inside. However; No light on front nor the networking port.

#4

Same thing is happening to me. Since yesterday I haven’t been able to access my Cloud. The (usually blue) LED at the front is off. I’ve tried to reset the unit, a yellow/orange light has appeared but then it went off again. I’ve unplugged power and ethernet cables, waited a few minutes, and plugged them back, the yellow/orange LED went on again, and then went off again. Still no blue light, still no way to access the Cloud. The lights in the networking port seem to be working though.

#5

It’s possible the power supply for the My Cloud has gone bad.