No Internet Access to Cloud

Hi there, would really appreciate all the help I can get regarding this issue I’m facing right now.
I have read through all the previous posts regarding how to fix this, and have tried most of the solutions, but none of them seem to work.

I’ve just brought back my cloud ex2 ultra from a different location and plugged it straight into my router. I’m currently using a DSL-N55U Annex Router.

This is the result I get for the FTP, HTTP, HTTPS services whenever I test whether the port is open or not.
I have:-

  1. Resetted my router & cloud multiple times
  2. Tried auto and manual modes

But everything results the same
portforward-fail

Here are my settings for my router for portforwarding & my cloud settings

cloud-access%20settings

Would really appreciate any help I can get to get my cloud working again.

Few extra things to note that complicates things:-

  1. Currently using DMZ and DDNS to expose another server to the internet for remote access (I think this may have something to do with interfering with the ports(??). Not an expert on this)
  2. Router (DSL) is currently connected to another Router (4G) for load balancing. (I’ve read that I may have to open ports on both routers or something. Not too sure about this as well)
  3. Router (DSL) is connected to a network switch with ~30 clients.

New users can only post 2 images. So here are the rest of the images