No Internet access for direct connection

Hi,

I have a problema. MBL does not have Internet access. I’m trying to make a direct connection because the performance is much better.

My setup is as follows:

MBL -> [ETH - Thunderbolt adapter] –> Apple Thunderbolt Display <– Router

With this configuration, the MBL can’t access to Internet. Any suggestion?

Thanks!

Interesting config… are you getting an IP for the MBL? That would be the first thing to check. If you are, what is the default gateway?

However, it seems this kind of adapter is to be able to convert a thunderbold port to ethernet. Think of it as a USB to etherner adapter. Not to connect a client, which would take you back to getting an IP.

Hi,

With this config, MBL gets the next:

IP: 169.254.37.4

Subnet mask: 255.255.0.0

Gateway: empty

DNS: empty

I think that the problem is to route the MBL to ADSL router to get a Internet connection. But I don’t know how…

that is your problem. That is not an address obtained from the router, but it timed out/could not find a DCHP server. Similar to:

http://support.apple.com/kb/TA26003

You could try to set static IPs to see if that works.

I tried to assign a static IP address, but no works.
Also, I don’t know if the static should be assigned to MBL or to Thunderbolt adapter interface.
I tried various configurations, but doesn’t work…

Thanks again!

“I don’t know if the static should be assigned to MBL or to Thunderbolt adapter interface.”

To both, and both have to be on the same network as the router. But even then, it might not be a valid config. Might have to play with gateway and DNS settings.