No HDMI No Firmware update

I bought a second hand WD TV media player, part #  WDBABG0000NBK.

I have two main issues…I have tried a factory reset and it dosn’t solve any of the issues.

1st issue - When I try to use a HDMI cable it states NO Signal. I have tried a number of different cables on three different TV’s.

I used a composite cable and manually selected HDMI Input and select auto resolution but the player switches off, fails to find HDMI and returns to composite input.

I have tried not using auto resolution but selecting a configeration but it does not change the outcome.

2nd issue - I have tried to do a firmware update and have followed the instructions exactly.

When I plug in the USB stick the media player reads the USB but no firmware update icon appears. You can locate the folder but it states no media when you open it.

I have tried Generation 1 & Generation 2 updates in the hope of finding a solution.

The current firmware is the factory original of 1.1.77

However when I use a composite cable I have NO problems at all. The player works great.

Any ideas or have I bought a faulty media player.

Thank you for any help.

Be sure to decompress the firmware update before you copy it to the USB memory. Have you tried connecting the WDTV to another TV?

Hi

I have tried it on three different TV’s.

The firmware update was done by myself and someone else exactly as instructed.

Thanks for replying.

1.01.77 IS the latest firmware for your device. Definitely not factory original.

Thanks for letting me know it is the lattest firmware version.

Looks like its just a HDMI problem then.

I have tried all the solutions I can find and hoped it was a firmware issue.

Its unusal for a HDMI port to stop working…

Nigelh6 wrote:

 Its unusal for a HDMI port to stop working…

Maybe that’s why it was 2nd-hand in the first place.