No Dolby Digital audio after 1.05.18

After updating to 1.05.18 finally i can see my m2ts file but…without dolby digital audio!!! 

All file m2ts, mkv, with dolby digital cannot be hear in multichannel but only in stereo !!! (DTS ok)

Please, fix soon this bug. Anyway great delusion with the wd tv live streaming firmware… 

Redo the setup. All audio is working fine for me…

There’s only four option on audio menu, and are always the same. With new firmware I can see M2TS but not wtih Dolby Digital. My old MKV’s movie with DD are played withou sound. I have also my old WD TV LIVE and there’s no audio/video problem.

On my new player there’s not a function to load the same firmware version so I don’t know what I do. I’m not the only one with Dolby Digital problem if you read on other post. The same player with the previous firmware version works ok with DD on MKV.

Just wanted to add that I’m experiencing the same problem. 

Anyway to rollback the firmware until this gets resolved?

Same procedure as always:

  • check these forums to see if someone ran into problems doing a rollback with this particular firmware version
  • check the link of the current firmware zip on the offical support page
  • paste it into your browser’s address bar and change the filename to the previous firmware’s number (which still may or may not be online)
  • download it and put it on an USB stick’s root directory changing the VERSION= in the wdtvlivegen3.ver to something higher than the one currently installed
  • reset your player to factory settings
  • attach the stick and procede with the update
  • do another reset to factory settings for good measure

I had been searching for how to rollback the firmware before I even made that post but didn’t have any luck as far as actually getting it to work so thanks for that.  I’ll give it a try.

update: Rollback worked and DD is back!

I updated to the latest SMP firm ware and all my TSs, MKVs and M2TS files play just fine. I am using HDMI pass through and it goes straight into a Denon receiver. No difficulties yet with DD or DTS.

It may just be optical then. 

Whatever the case it was the definitely the firmware for me because as soon as I downgraded DD started working again.

I also no longer have audio on any of my hidef (mkv) videos.  audio works fine on all my standard def (stereo) videos.  I am also using optical via my reciever.  everything was working fine before the firmware update.

which rollback procedure did you follow to get back to previous firmware?

I used the procedure outlined a few posts up and used version 1.04.12.  As far as I can tell this was released last month:

http://community.wdc.com/t5/News-Announcements/New-Release-Firmware-Version-1-04-12-for-WD-TV-Live-Streaming/td-p/295302

If you run into any problems let me know and I’ll try to  help.

Yes I can rollback to the previous firmware but…why? This is not a good soluction! With 14.04.12 I can’t use my .ts .m2ts file, With the new one I have lost Dolby Digital. I Think the only good soluction is build up a new firmware and sono because i purchase my new Wd Tv live streaming 1 month ago and I can use it. My wd tv live is connected With optical cable to my amplifier. For now I can only use my old wd tv to see and hear all my file…

I have a similar problem with audio. When I start playing a HD video (.MTS via HDMI), there’s audio and the audio leads the video by a second or so. Then, after 54 seconds the sound level drops a bit and two seconds later…no sound any more. Pressing pause/play brings back the sound for a few seconds. Stereo or DD settings makes no difference. Release 1.03.10 and 1.05.18 both show the same behavior. What to do? Wait for a new release? Does anybody know if there’s a way to get at least some sound until this is properly fixed in firmware?

thanks for that.  i have just rolled back to 1.04.12 by following instructions here:

http://wdc.custhelp.com/app/answers/detail/a_id/5860/related/1/session/L2F2LzEvdGltZS8xMzI0OTg4MDA5L3NpZC9qS2pyVERNaw%3D%3D

i can now hear DTS audio using optical audio again.

Are you sure you can’t use .ts or .m2ts with the older firmware?  When I first got this back in late October I was playing those files with no problem. 

I just tested .ts and .m2ts videos and they work fine with the 1.04.12 firmware via optical audio output

Yes I’m sure, on my screen there’s a nice screen with " file not supported". If you read on the bug fix list of the new fimware there’s the soluction for “• Resolved content playback issues with MPEG2 and MPEG4 BluRay ISO, M2TS and .TS.”

Now I can use it but if there’s a dolby digital audio, I can’t hear anything, only DTS works.

Same file with old Wd Tv: no problem at all. I can see and hear everything. There something wrong on 1.05.18

I loose  too many hours with hard reset, restore to the factory, relaod firmware. I just want see my movies folks… :slight_smile:

I see.  Sounds like there was just an issue with playing certain types of .ts and .m2ts files opposed to playing them period. 

Are these files ya’ll are having no audio on strictly Dolby Digital 5.1?   Or are they Dolby True-HD?   

If they’re the latter, from what I understand, optical cannot support that because of the high bandwidth required.

… if the prior firmware worked, it may have been because True HD was NOT working correctly.

Now, with new firmware, dolby digital can’t be played also from MKV’s files with simply DD. All files with Dolby Digital are displayed but without sound.

I have some file with true HD but also with old player was unsupported by my amplifier so, with DVD Fab I delete the HD tracks and it works.

-With 1.04.12 Dolby digital and DTS was played without problem (on .MKV) but .M2TS and .TS was “unsupported” by the firmware.

-With 1.05.18 .M2TS .TS .MKV now are played correctly but I can hear audio only if there’s DTS, no sound from Dolby Digital.

With my old player ALL file running well.

Yeah, something’s definitely wrong with your box or setup.  

All dolby digital is still working 100% fine for me, regardless of the file type.

If you haven’t tried already, try doing a restore to factory defaults.