No Documents Shown on Passport Drive but Storage Area is occupied


I have a WD passport drive, where I have saved many files as backup. When I tried to reach them, it was shown completely blank as no files or folders are displayed. But when I check the storage area, more than half of the space is seemed to be used. So, my files are there, but I cannot see them.

I have already tried viewing hidden files, “unchecking” operating system files, but they did not work. What might be the problem and what should I do?


Ps. My device is quite old (around 8 years).

Did you try to check the storage space after the formatting of drive?


Thank you for your feedback. If I format the drive, I will likely lose all data; right? Or am I missing something?

I tried Recuva software to retrieve the data. It actually found the documents in the drive, retrieved them to my hard drive, but whenever I tried to open them, system gave error. For example, if it was an excel file, it showed up some symbols when I opened the file, or if it was a jpeg file, it said the software does not support this file, etc.

Bottom line is, I definitely have files in the drive, cannot view them when I plug in the drive, and whenever I try to retrieve my other means, the files are not read correctly.

Seems like I am out of options at this point, but if there is anybody out there who could give an advise, I will appreciate it.

Thanks a lot.