No Connection!

Ok, I’ve had a very hard time trying to get this to work.  I have been trying to set the Media Hub up in my room but there is no internet connection there.  To plug it in I would have to run an ethernet cord the length of my house.  So I decided to get a USB wireless adaptor. 

I purchased (from best buy) the Netgear WNA1100 USB adaptor because I have the Netgear WNR2000v3 Router and I like to stick with the same brand to avoid issues (especially when it comes to networking).  Just in case your wondering -yes it is on the list of compatible devices with “NEW!” next to it.  Unfortunately the Media Hub made no recognition whatsoever of the USB wireless adaptor.  Tried a few different ways and read a lot of not-very-helpful stuff online and gave up.  Then I figured at least for now I could put just copy my media onto the WD TV Live Hub and just watch that until i figured out the internet problem.  

I didn’t have a double male end USB cable so I just plugged the ethernet cable into the back of my Mac Pro from the back of the Media Hub.  Nothing showed up on my computer. 

So then I did a little more searching/reading and found that you can just transfer over the network so I then took it across the house with a monitor and plugged it straight into the Netgear router.  No connection, no change whatsoever.  I have reset it multiple times to no avail.  I read online that someone solved a similar “netgear router” problem by installing an older firmware.  Went to the Netgear site only to find that I have the only firmware version that was ever available for my router so I can’t upgrade or downgrade it.  The WD TV Live Hub so far has absolutely no use to me outside of watching the sample videos.  I can’t transfer anything to it and I can’t make it connect it to the internet.  If you can help me on either issue I would be most appreciative.  If I can transfer videos then I will deal with the connection issues later.  I’ve spent all day on this thing and I’m exhausted, please someone just tell me that I’ve done something stupid and/or just help me out.  I’m getting remarkably frustrated and am really tempted to return the thing just so I don’t have to deal it.  Any help would be greatly appreciated.

Router:  —NetGear Wireless N WNR2000v3

USB Wireless Adaptor: —NetGear Wireless WNA1100

Computer: —Mac Pro 1,1 - Mac OSX Snow Leopard 10.6.8

Ok.  Lots of things to cover.

The WNA1100 is marked “New!” because it’s only supported in the newest firmware.   Have you updated the firmware of the Hub to version 2.07.17?   You can do that via a USB Flashdisk or USB hard disk.

You cannot use a MALE-MALE USB cable even if you had one;  that’s not possible.

If you piggy-back the Hub on to your Mac Pro’s ethernet port, you have to make sure both your MAC and the WDTV are configured MANUALLY with IP addresses in the same subnet.  You also have to SHARE your Mac’s HD with the Hub (I don’t know how to do that on a Mac.)

Even plugged into the NetGear router, you still have to configure the Hub to work with your local network and your MAC.

So you’ve read lots of stuff on the forum.   That’s awesome.   :slight_smile:   But have you read the manual?   A lot of this stuff is covered there.   Also check the Knowledgebase articles on how to configure your Mac to work with the Hub.


But in general:


Had no idea there was a manual, LOL.  Thanks for the help, I’ll start with trying to update the firmware.  I’ll post the solution when I get it figured out, thanks for all the suggestions.  My Mac HD is shared over the local network so I do know its not that at least.  I guess I just assumed the drive would operate like an external HDD and that my computer or the Hub OS could simply read/write to…

I just downloaded the firmware update and I’ll post as soon as I install it so if anyone else has a problem with the Netgear USB wireless adaptor they can find the answer here. 

I do have another question though, If I update the firmware and plug in the USB adaptor do I have to configure anything or will the “automatic” option connect me to my network? You said:

—“Even plugged into the NetGear router, you still have to configure the Hub to work with your local network and your MAC.”—

When I plugged it in by ethernet the “automatic” setup said there was no connection.  My network is open with no password and my Mac HD is shared on that network.  Outside of setting a manual IP address what kind of configuration would I need?  Shouldn’t it just receive an automatic IP like my other devices?  Thanks again for the help btw.

Yes, Automatic should work, and it will tell you if it is able to configure or not after you go through the Network Setup.

I completely forgot to post when I had this figured out but the firmware update definitely solved my problem. After that the USB wireless adaptor worked fine and ive been transferring files regularly. The only thing that kind of annoys me is that there is a ton of lag if I try to watch wirelessly from my computer but I honestly think it’s because I have literally a 4.something terabytes worth of media on the thing and every time I connect I don’t think it’s ever finished “compiling media library” lol. Everything else has worked splendidly though. Thanks for the help guys. It’s not perfect, but for all the other options out there, WD definitely takes the cake. Being able to just carry around a tiny device and plug it into anything with a huge media library on it solves about 20 problems for me. I can guarantee I’ll be using this thing until the hard drive craps out on me. My one, painful complaint is that you can’t rename files or folders or even make new folders. In the end I can deal with it but it just seems like such a simple thing to add. Obviously I could be wrong and it could be a programming nightmare. I just had to mention it because it’s the only thing that really bothers me. A tip for anyone who is or has bought the WD TV Live Hub; organize your files on your computer by name AND folder before transferring. If u have as much media as I do it might drive u crazy to delete and resync a file just so the name has “rifftrax” before the title rather than afterward. Definitely the best option available though and if it can be done I don’t doubt it’s an update or 2 away. Thanks again!