NO connection with network!


     Right, this has happened everytime i’ve tried to set the device up.

I have the latest firmware

I have tried factory reset, i have tried power cycling

It works on another network (i have tried it at a friends)

I have all firewalls and anti virus’ off

I begin the set up process, it sees my network, i select it. I have give the p/w then it goes to the connect automaticall or manual screen, i choose auto. It then start trying to connect. When it eventually times out it says: “Unable to connect to the internet. The WD TV has limited or no network connectivity. Please retry or manually input the network informatio to connect”.

This is the only device i use that doesnt connect straight away, there are two iphones and a macbook on it also.

The fact that it works on a different network means the issue my router? But i’m confussed at to why i can connect other things to it with no hasel. 

Any help with this would be greatly appriciated, i’m starting to loose my mind!

Oh and the router is a D-Link DSL-G604T



After the auto configuration fails, check to see what values it was assigned for

IP Address

Subnet Mask

Default Gateway


Im not sure what you mean, how do i do that?


After i enter the p/w for my network, half the time it goes straight to trying to connect (then fails), without taking me to the Auto/Manual stage. The other half, it takes me there but at the top of the screen where it says Network name (with the manual option for IP Address, Subnet Mask, Default Gateway, DNS under that), the network name that comes up is my neighbours, never mine…