No connection to MBL

I have lost all connections to my MBL…  It’s plugged into my ADSL modem/router.

I’ve Windows 8 64-bit and had MBL mapped as a drive.  I connect to the router via wifi and the drive talks to the router via a network cable.

While I’m aware of the issue with Windows 8 (exclamation mark in Device Manager), at least I could access the drive.  Now, the drive has disappeared from Device Manager.

I can’t even access http://mybooklive/UI/ and I plug the drive straight to my computer (via a crossover cable).  To bypass Windows 8, I tried to use the WD2go app on my iPhone or from a different computer and it can’t talk to the drive.

I’ve also tried resetting the drive, but that made no difference.  All the lights on the drive are showing no problems.

Any assistance would be appreciated…

The front status light in the front should be Green. Try using the WDlink app to map it.

Yeah, the front light is green and often blinking…

I’ve also tried the WDlink app - it can’t see the drive either…?