No Cloud Functionality

Okay, let’s review the situation.

You see two ‘MyCloud’ entries in your Windows ‘My Network Places’ (this is normal; one is the user file system, one is the control interface).
You can access the user file system on the MC via your PCs.
You cannot access the control interface, even if you disable your antivirus and firewall.
You can successfully ping the device’s IP address.
You get a blue light on the front panel.

Since you can access the data and ping the device, the device is accessible via your local network.
This pretty much rules out router or cabling problems.
It also demonstrates that the MC hasn’t simply ‘bricked’; it is basically functional.

You cannot access the Dashboard using the URL http:///UI
This suggests that the webserver on the MC is not running properly, for some reason. I’m assuming that the MC uses the apache webserver to provide the Dashboard interface; others may be able to confirm/deny that assumption.

When you run one setup program, it appears as a MyBook Live, but you do not have a MyBook Live on your system.
This is very confusing…

When you run another MyCloud setup program, you cannot connect to the device.

You have tried a 4 second reset.

You have tried a 40 second ‘system restore’:
“held in the pin reset switch , waited 40 seconds and powered up”

Your wording here is a little unclear. The sequence needs to be:

  1. press and hold the reset button

  2. apply power

  3. continue holding the reset button for 40 seconds

  4. release the reset button

  5. allow the MyCloud to boot

This ought to do a system restore, which ought to restart the web server, assuming it has failed.

If this doesn’t work, there may still be options.

I think SSH is enabled by default, so you ought to be able to use PuTTY to SSH into the MC on port 22 (user ‘root’, password ‘welc0me’; yes that’s a zero), and access the linux OS. If you can get in via SSH, there are probably a whole raft of options, such as checking to see if the webserver is running, restarting it, etc.  I’m not that familiar with those operations, but others may be able to help.  It would probably be something along the lines of ‘service apache status’ and ‘service apache restart’.  You might even be able to reboot the device from the command line, using ‘reboot’. Again, I’m not too experienced with this, so others may be able to provide more detail.

I recall seeing a thread on updating the firmware via SSH. If you can upgrade firmware and reboot, this really ought to force a clean system boot. You could use this method to install the latest firmware, rather than downgrading.

Finally, if you cannot get the device working, and you have an email exchange with WD to show that you had problems from the outset, the UK Sale of Goods Act may come to your rescue. SoGA has precedence over warranties, and gives you rights to return items that were faulty from the outset (an ‘inherent fault’). But the contract is with your supplier, not with WD. If you bought the device with a credit or debit card, your bank statement should be adequate proof of purchase.  Before you do this, I’d still suggest you try WD Support again.

As for WD’s support, yes, my experience is that they fail to read emails you send them, even in email exchanges. But I understand that there are levels of support, and I suspect I’ve never got past level 1… I have also never tried ringing their support line. And, to be fair, it’s not their fault that your spam filter put their emails in your spam folder…

1 Like

Thank you. all fair comment and some useful options in there, - I WILL persevere and keep trying.

Im pretty sure the sequence I used for resetting with the pin switch matches yours but Ill try that again too.

As Ive been using the unit as  a network or ethernet drive  & for backup , all the files already exist on my system, so a complete factory reset and wipe wouldnt lose me anything.

As for  accessing the linux O/S and using that, I think I could probably cause more damage than good even though Im pretty conversant with linux, I understand what youre outlining but am reticent about messing with the O/S.

The device IS still under warranty as I had the foresight to register it but as you say, whos to say a replacement might be exactly the same, also the news that  refurbished units are used  unsettles me. - This device was brand new and has very few disk hours on the hard drive, I dont REALLY want to swap it for a second hand reformatted one with god knows how many hours on the drive. i.e I paid for a new unused drive so thats what Id expect as a replacement. Another point is that the thread you posted  sorta gets lost with the first line:-

  1. Enable SSH

- login to your WDMyCloud dashboard ( http://wdmycloud/ ) -> go to Settings -> Network -> and change the slider for  SSH to  ON

(I cant access the dashboard, thats the main problem, so if SSH is NOT enabled Im stuffed anyway).

 Im assuming you mean running the commands in the thread from port 22 with PuTTY and not having to enter the dashboard at all,well, not really an option for me as I have no experience of PuTTY at all, Id be  more than  a bit lost doing that.

(As for the emails going to my spam folder, well I can blame that on my IP provider, their spam filters are pants (BT).

I DO still have the Email exchange and a record of the transaction as I saved them when I did find them but the actual paper receipt is sadly missing).

Again Im grateful for your help, it does seem like Im running out of options though, all I can do is try support again and pray.

Thank you both.

SSH: yeah, I read the user manual after posting, and it says it defaults to OFF.  I did stress “I think SSH is enabled by default”…

Bah.  But sensible from a security PoV.

PuTTY is simply an SSH access terminal.  There’s nothing fancy to learn.  It just allows you to log in via SSH, and get a linux command line interface.  I’d never used it before, but I downloaded it, installed it, and logged in straight away.

Yes, logging in as root might be a bit scary, but if you’re familiar with linux, you’ll know what commands are safe, and what aren’t.  Just don’t go typing ‘rm -R *’…  You may not need to go as far as upgrading the firmware via the linux command line; it may be possible to find which of the services is broken, and fix that, or reboot the system.  I’m most certainly not a linux expert, even though I’ve been using unix systems since the days of the Sun Sparcstation.  I’m not familiar with the ‘guts’ of it, but google is pretty helpful.

Download PuTTY (it’s free).  Install it, and see if you can log in.  That’s the second step (after trying the 40s reset).  At least we can then rule out one set of options, or find that we have another way of seeing what’s going on.

Remote debugging is hard.  It requires debuggers to build up a mental picture of what is going on.  Which requires full, concise and accurate information about the system.  Hence my attempt at summarising.  If there’s anything inaccurate, then let us know.

Oh, and the 40 second reset doesn’t do a ‘full factory restore’, so you shouldn’t lose your data’.

Missing receipt: as earlier, most reputable shops will accept other proof of purchase.  It may even be covered under SoGA.

1 Like

I’m really sorry that you’re having such a good time with your installation.

I was pretty annoyed when I found out the WD email cuatomer support was separate from their telephone support. I treated the email support as non-critical and sorta expected somewhat timely responses but found out their service level is 24 - 48 hours (imo that’s at best). I found that telephone support was available, knowledgeable, and corteous. In my case they escallated the call to level 2 and then to engineering within the same phone call.

I stronly suggest giving telephone support a try at this Eurpoean # Toll Free/UFN   800-8558-4253

1 Like

Well I finally have access to the elusive Dashboard.

I turned the problem over to a friend who went over all my systems network settings with me, my router configuration & tested all my ethernet leads and tried his hand at helping me solve it.

The result was that we tried the pin reset one more time and it WORKED at last, no idea why, we did nothing differently apart from leaving the device unpowered for 15 minutes with all its leads out before resetting it.

Its excruciatingly slow but at least its working now. Nothing was changed with my actual PCs configuration.

It does seem very hit and miss with its media serving though. On my ipad it`s not TOO bad though still very slow,(about 14 seconds to seek and play each track),but on either android, even on the same wifi network even, its MOLASSES slow. (Approx a MINUTE to display the directorys with a further 30 seconds to a minute to poll any further navigation and then a MASSIVE, (unmeasured as I got bored waiting), gap as it trys to open the track, I THINK it took about 5 minutes.

Is this normal?

BTW I received an Email from WD support (and NOT in my spam folder wonder of wonders lol), it seems somebody has seen this thread. :wink:

I`ve two final questions.

Now I have access I have the option of updating the devices firmware but I`ve seen a few threads here for people to roll back or update either the devices firmware or the twonky beam media server firmware.

  1. Is it worth doing and will it gain me any better performance?

(I`m reticent about messing with it now its working to some degree).

  1. is there anything I can do to improve the response of both the device in explorer, and on my phones/ipads?

Im really not bothered about its timemachine backup function or anything else that it does. (It simply doesnt have enough space for my data anyway).

The original purpose of the purchase was to keep a copy of my media and primarily my music library as both backup and to make the media accessible on my mobile devices, both in my home and when I`m out and about.

(I actually went out to buy a simple usb external drive, saw it and it was roughly the same price, so I bought it for the functionality. - I originally intended using Tonido with a USB drive).

  • And its failing to do this on account of its dismal response time… as a media cloud server it`s, err… Pants. Waiting 5 minutes for a track to load is just not something I will put up with.

I`d like to thank you all again for your help, you guys are a light in the fog for struggling users on this board.



I was curious about your remark:-

“I’m really sorry that you’re having such a good time with your installation.”

are you a masochist? lol

Thanks for the support number, Ive filed it way for reference.

oh and something else I do want to mention.

earlier in the thread it was suggested that using SSH to access the Operating system would be one method of resetting the server.

People should be aware that doing this may void the devices warranty.

From WD`s own FAQ pages:-

Critical: The use of SSH (Secure Shell) can potentially harm the hard drive and could result in the drive and the data within it becoming inaccessible or lost. The use of SSH to tamper with the drive in order to modify or attempt to modify the device outside of the normal operation of the product will void the drive’s warranty.

Yay! Glad to hear something worked. Was is a short reset, or long reset? Did you get to the bottom of the MyBook/MyCloud setup confusion? I ask because solutions may help other people in future.

Now for the next problem… You say that media access is very slow. What are you using to access media? A file browser? The WD MyCloud app? A UPnP/DLNA app?

I’ve tried many UPnP media apps, and they all take a few seconds to get the media database view up, but I do have 62k tracks. But it only takes a few seconds to select and play a track, and a playlist moves from one track to the next pretty sharpish. Certainly not minutes.

How long is it since you put your media on the drive? Could it still be doing its indexing and thumbnail creation? Oh, it’s been there a while, hasn’t it…

After much fighting with the Twonky media server, I’ve got mine stable, and it even survives reboots. I wrote up my findings here:

Downgrading firmware? I’m running 4.01.01-413. Not the latest, but the recent upgrades have been for Apple stuff I don’t use. I’m waiting for the fix of the security holes before I do an upgrade, since upgrades cause grief for Twonky.

Yes, SSH does come with a warning. But it does come as a feature of the product. And, as I’ve said before, if the thing worked properly out of the box, we wouldn’t have to go mucking about with SSH logins and fiddling with Linux admin tools…

Oh, and the WD website also says you shouldn’t make changes to Twonky via the Twonky UI. But it provides the Twonky UI and describes the settings… They only say that because Twonky isn’t properly integrated into MyCloud, and MyCloud trashes any changes you make via the Twonky UI. Although it can be discouraged from doing so via SSH login…

it was a long (40 second) reset.

Im wondering now if theres an actual hardware issue with the pin button itself, its just possible I have not been resetting it at all,- there was no "give" in the button, This time I was quite brutal about holding it in and felt it "give" slightly under pressure, since then I can feel it "click" as Its pressed.

The myBook confusion MUST have been me hitting the wrong link I guess although I was careful in selecting my device, I`ve since tried it again and it downloads and runs the MyCloud setup.

I`m using the WD app in android  and on the ipad.

There IS  a lot of media on the drive (didnt realise how much actually,  I have  only 250GB free out of 3TB) though it IS a 3TB drive so should serve the entire drives capacity, its a bit pointless having to limit your library size  in order for it to work correctly. Maybe its time to reorganise the directory structure to see if that helps, (atm all the albums are in one directory in their own folders, I`ll investigate that possibility.

Firmware:-  I mean downgrading OR  upgrading, what seems to be the best iteration to use ?

I`m using the WD app in android  and on the ipad.

Ah, in that case, I think you’re browsing the file server, not the media server.

I don’t use the WD app for anything; I think it’s generally recommended not to, unless you need remote access (and I don’t use the cloud access because of the security vulnerabilites, and because my ADSL broadband uplink rate is only about 0.5Mbps, not good enough to stream my media).

On the PC, I’ve mapped my drive, and parts of it, to drive letters in the PC’s file system:

N: to the top level (NAS)

M: to Public/Music

P: to Public/Photos

V: to Public/Videos

On Android, I use File Manager, and connect the MyCloud as a network drive.

On the iPad, I use FileBrowser, and connect as a network drive.

For media, I use UPnP/DLNA apps, including BubbleUPnP

 it`s a bit pointless having to limit your library size  in order for it to work correctly.

The indexing and thumbnailing process doesn’t go on forever.  But, whislt it’s running, it takes a lot of cpu and slows the MyCloud.  Not sure if yours is still doing this; if your media has been there a long time, it ought to have stopped, but if you’ve recently done a system restore, it might have decided it needs to do it again…

The media library size is more to do with the number of files, not the space used.  If you have lots of videos, you may not have 65k files like I have, but each takes up a lot more space than my music files.  This is a problem for all media systems; as the library gets large, the database gets unwieldy.  Look at media library blurbs; they’ll all try to tell you that they’re good at handling large libraries…  I use MediaMonkey on the PC, and that’s supposed to be good with large libraries, but even that takes quite a while to load its database when I start it up.

I’m not a WD apologist in any way, but I have to be fair to the MyCloud and say that large libraries are hard to manage on any platform; to load and parse a large database takes time.

That said, you are having unusual access issues if it’s tqaking minutes to access a file; this is not my experience.

Maybe its time to reorganise the directory structure to see if that helps, (atm all the albums are in one directory in their own folders, I`ll investigate that possibility.

The structure I have long used is a three-level hierarchy:

Album Artist/Album/Track

A decent music library tool will enable you to re-structure your physical library based on the metadata.  MediaMonkey has a very powerful system for doing this (Auto-Organise); it can even unmangle the obfuscated file system on iThings.

Firmware:-  I mean downgrading OR  upgrading, what seems to be the best iteration to use ?

Sorry, I can’t help there; I haven’t played much with firmware upgrades, and haven’t noticed any great differences in behaviour when I have upgraded.

personal opinion is the 1st v4 FW was bad and should not be used. I have used several of the later ones with no issue so upgrading should be fine especially if you are not loading any other programs in Linux

are the android and ipad wifi connected?

how long has it been since the 40 second restore? with a lot of media it can take a few days to settle down. what is a ballpark for # of songs, movies and pictures

can you try Winows media player in both DLNA and filesystem modes

I am happy to hear you can finally get to the Dashboard ffsffsffs :smiley:

Yes I (was) using the WD app, That has now been kicked to the kerbside as useless as now the ipad won`t even connect and reports the device offline in both ipads and the android just hangs for ages when I try to do anything with it.

I had exactly the same file structure in mind though my plan WAS to use

Genre/Album/track as intelligent directory naming and the alphabet will take care of artists names.

Metadata is great if the albums metadata

1.Exists  or

  1. Has been entered and tagged correctly, I find that lots of my purchased content does not.

The (windows) media server icon for this device has appeared on my network now but reports as completely empty.

The thumbnail process does take a lot of resources up and I could have lived without it, it would have been useful to be able to turn it off.

I did map my shares and there was a slight improvement in speed in Explorer, that said, it was still pretty slow.

Even logging in in a browser is excruciatingly slow.

After looking it over and finding these further issues I think the time has come to just abandon the idea of using this for my music, its really NOT fit for purpose.

It`s much too “hit & miss” with that function. (mainly “Miss”)

It`s buggy, unreliable and hard to even get up and running.

The main issue is speed and it`s terrible response times, but with the added problems of just getting it to function,

I think Im just going to abandon it completely. Just wish Id found all this out  a year ago.

I would recommend sticking with the Artist/Album/Title structure for your physical library. This structure reflects the physical CDs, so you can re-rip if necessary.  Those three values are indisputable…  That’s advice based on long experience, and echoed in most guides to setting up a media library.

Genre is metadata, and a matter of opinion.  In my limited experience of downloading metadata, genre is without doubt the least reliable metadata value (and, as you say, online metadata is questionable).  Almost all of the metadata on my collection has been entered by me, typed in whilst ripping the CDs.  I have bought no downloaded music…

A DLNA media server will add a track’s metadata to its database, and will allow you to view the database using a large selection of views, based on sorted metadata.  You can slice and dice views as you like.

I think it would be a shame to abandon it now, as you seem to be getting close…  It is possible to disable the indexing and thumbnail services:

Or just give it a week to see if they shut up.  Mine have, and my system is calm, stable and responsive, and I can stream media and use as a NFS locally.

If you don’t need the streaming, or local, always-on, networked access, just get a big USB disk; it will be quicker than the MyCloud, and will need no maintenance…

You might also look at your router: many have a USB port that it will use as both NFS and media server; my Technicolor 582n does…

Thanks cpt_paranoia,

Genre would be vital to me normally as one of my pastimes is mixing and DJing, sorting my music by by genre helps me to choose tracks according to a programs theme and thats the way I have it arranged on the machine I use for DJing. As Ive been using this drive as a backup Ive just thrown each album onto it in one directory. - Probably should have matched the library I have I know, but it was convienient for me at the time because I was not actually playing the tracks directly from the drive.

Whats really bugging me at the moment is the devices inconsistency, one minute I can access it, then its inaccessable to everything and I have to reboot it. Either that or its  unusably slow. And Im referring to ALL aspects of using it, - its slow to boot, slow to log in, and Grindingly slow to find or play tracks even when accessed from the same network. (lord knows how it slow it would be on a cellphone via a cell connection). If it were a PC  Id be swapping the hard drive as faulty.

This drive is presented as plug and play and that it certainly is NOT, as there are so many parameters you have to address to get something useful from it. Setting it up and using it with the ease WDs glossy adverts suggest is pure nonsense, you HAVE to have some knowledge of networks , configurations and all the hurdles Ive faced so far.

The instructions  for it are a joke, - all there was in the box originally was a card with a web address on it (which was 404).

I`m certain my router does have a USB port so I think thats the route I will take, and this awful drive can be consigned to oblivion.

Ah.  Don’t keep rebooting it.  Every time you do that, you will restart the indexing and thumbnailing, and those services will never finish.

Turn it on and leave it for a week, if you have that much media.  Or look to disable those services.

Once it’s settled down, it should behave much better.

I agree with all your comments about poor instructions, difficult setup, and it not being the ‘simple 1-2-3’ experience it says on the box; I’ve made all those comments repeatedly on here…  But, having got it sorted, it is working okay for me now.  With some limitations that I continue to bring up…

But if you don’t want anything more than a simple backup device, I.e. you don’t need it available as a 24/7 file server, and you don’t want a streaming media server, and you don’t want remote access (when they fix the security holes), and you are happy to organise manual backups, then you are probably better off with a large USB drive that you connect to your main media PC, and back up your media as you see fit.

As for the media library organisation, I guess that will depend on how you select and play music when you’re DJing.  If you select music using your physical library (I.e. the file structure as music is stored on the disk), then your genre-based structure may be best for you.

But if you use a music library tool to select and play music, then it will almost certainly have the ability to allow searching via one of any number of logical views, based on the metadata; MediaMonkey certainly does this.  And yes, whilst metadata is sometimes questionable*, you can change it to whatever you like…  

How fine-grained do you want your genre categories to be?  Music genres are a nightmare to keep track of, and are ever-changing and subtly nuanced, so there’s no obvious transition point; one genre simply segues into another… ‘House music’?  I give you:

And that will be out of date…

But whatever you choose, your backup should be a mirror of your original; if will make maintaining the backup much simpler.

* I ripped ‘Born This Way’ last night, and freedb had it as ‘New Age’,  Deep Purple’s ‘Stormbringer’ came up as three options, none of which was Rock.  So I corrected the errors, and ripped the CDs…

"Don’t keep rebooting it.  Every time you do that, you will restart the indexing and thumbnailing, and those services will never finish."

I don`t really seem to  have a lot of choice because I lose access completely, (on the PC too it just hangs to a white screen).

Also gotta stress that I WAS using it as a backup. - Purely because I could read and write to it and didn`t want it to sit useless, it was purchased for the web access after the intention of buying a USB drive and sharing it via tonido both as backup AND to provide cloud functionality.

Most of the programs I work with, (seratoDJ, Traktor,VirtualDJ, Ableton Live & others), have their own databases/File Managers built into them and draw their content from the files on the drive, and yep there are MANY  genres, (and they are being added to every day), I keep them down to a few generalised groups for simplicity  e.g. Ambient/Chillout/Downtempo/Lounge/Lofi/Minimal in the same folder, - I rely on my own knowledge of the artists and albums to sub-categorize them if needed or sort them in the Mixing softwares file managers. I use 29 main categories but the music I mix and work with is predominantly Trance/House/Dance/Club and the sub genres of that, so most is in just a few directories. I find this quite manageable and easy to keep track of.

I think Im going to have one last go at this by doing a complete wipe of the drive, (a full factory reset), & Ill re-install everything from scratch and see where it leads me. I may just store the music I use a lot on the drive and trim the content right down rather than storing everything I have on it, hopefully with a better directory structure and a clean install it MAY be better. If I have no luck I will just use it as I have been doing as a mirror and backup. Part of me wants to just sling it through the nearest window tbh but I DO want to have something to show for the money I paid for it so will have one last go.

Wish me luck.

We DO wish you all the luck in getting this device to work.  :wink:

You always have the option for a RMA as a last resort … if it isn’t working now, what do you have to lose other than the time it takes to restore all your files and set everything up again.

You could get a Synology or QNAP and pull the HDD out of the My Cloud and use it. I know that is more money, that we all don’t have … again, what are our choices?

My Son-In-Law uses Ableton Live and VirtualDJ, he wanted to get a My Cloud for storage and streaming. I talked him out of it because of all the issues I have.

 I don`t really seem to  have a lot of choice because I lose access completely, (on the PC too it just hangs to a white screen).

How long did you give the indexing & thumbnailing to run?  We’re not joking when we say it might need days.

If you just use the drive for backup, and don’t need live access to it, then why not give it a week to settle down?  It’s a one-off task, and when you add new media, it will only need to do a delta.

Or take our advice and disable the troublesome services?  It’s pretty straightforward to do.

A full factory restore will take days, so be warned on that. Plenty of threads discussing that.

If you do choose this route, I’d urge you to kill thge indexing & thumbnailing tasks before you start transferring music.

It will take a few days to copy your media onto it.

Apologies for the egg-sucking advice on genres (well, it is Easter). You obviously have a good handle on how you work, which may be different to how an ordinary music collector/player works.

And yes, we do wish you luck…

1 Like

@ ffsffsffs 

I totally agree with  cpt_paranoia about letting your MC settle down / in to what you’re attempting. 

I had all sorts of symptoms in the beginning (about one month ago) that miraculously cleared themselves by setting up one activity at a time, in my case I wanted a single point backup for my home so I proceeded as follows:

  • Installed a 10/100/1000 switch so I could physically connect each devide one at a time for it’s first backup
  • Disabled cloud access and media sharing
  • After all my Linux machines were successfully working with MC started on Windows 7
  • After Windows 7 was working connected My Book Studio (formatted ext4) and created a safepoint
  • After successful safepoint configured Mac Book Pro Time Machine
  • Turned on autoupdate for safepoint to occur at 3am
  • Eventually decided that having a safepoint backup my computer backups was redundant and configfured most backups to My Book Studio
  • Retired a 1TB ESATA drive and moved all it’s files to MC and now use it for shared data for all computers.

I strongly :wink:suggest that you pick the one that’s most important to you and let if finish and then move onto the next most important.

Thanks for the advice , Ill take it to heed. Time I have plenty of so Ill just put this on a back burner for now and do things  1 at a time as per your advice. Ill look at this thread in a couple of weeks and report back after Ive tried all you suggest and given it plenty of time.

Ive now bought a standard USB drive (not WD coff,coff),and its happily connected to my router and working beautifully.