No Chance to Recover my WD Live Duo?

Hi Folks!

I’m lost.

I read a lot of threads here and i think i’ve broken my WD Live Duo with following actions:

  • 2 years ago, i edited some configs and stuff that my NAS doesn’t has a dashboard anymore and stuff like that the NAS always is online, no power safe… everything to increase speed.

  • in the past two days, i backupped everything from the NAS to reset it 100%… I want my dashboard back… and everything as it was.

  • i uploaded this Firmware ‘apnc-024303-022-20130916.deb’ to public and connected over SSH used this command:

/usr/local/sbin/updateFirmwareFromFile.sh /DataVolume/shares/Public/apnc-024303-022-20130916.deb

i waited around 15minutes… nothing happened… so i thought, to reset everything to factory… and here is the BIG FAIL:

I FORGOT, that in factory settings, ssh is turned OFF.

…as i wrote… i used a command for resetting to factory and after that:

shutdown -r now

after all, the live duo had it’s factory name. I was happy first… but than:

I can’t connect to the NAS over dashboard… neither over ssh. the only thing that’s online is the nas’ Public Folder.

When i try to connect to the nas and it’s asking for user/pass… admin/admin doesn’t work.

ssh refuses always the connection.

Do you have any hint for me, to fix the NAS to it’s default settings including everything… back to the stage i bought it?

You would safe my **bleep** :slight_smile:

Thanks in Advance and please ask if you don’t understand anything. (English isn’t my mothertongue)

lostinabox.

It looks like you did  a debrick process from teh command line.  And it seems that the process was successful since it ended and you were able to reboot from the commandline. This means that the OS has been reinstalled and is factory reset.  Which means that you will not be able to see the shares until you re-establish them in Dashboard.  I am willing to bet that Dashboard is working, but that your browser is loading from cache.

  1. go on your router and find the IP address of the MBLD. 

  2. clear your browser cache

  3. go to Dashboard by http://IP_Adress_of_MBLD/UI/ #    (eg. 192.168.11.101/UI/# )

If that doesn’t work, try it with another computer or another browser.

The Dashboard password will be the one listed in teh user manaual - the factory setting.

And if you haven’t tried it already, you might try the reset button on the back of the MBLD.  It will reset to factory. 

If it does not work, then take the drive out of the box, and do a full debrick  (not losing your data) using the OS listing in one of the guides.  For some reason the OS version is important - I once did debrick with the latest version of OS and it didn’t work, but when i reverted to teh old version listed in the guide, it worked fine.  That could be your issue also. 

When you get this MBLD working again, then i highly recommend that you do the following

http://community.wd.com/t5/My-Book-Live/GUIDE-How-to-write-a-custom-firmware-to-your-MBL/td-p/575563

It will make it possible to reset your MBLD to a configuration that you choose simply by the reset button.  An external fail safe in case you ever mess up the MBLD. 

Just a word of caution from someone who has done a lot custom configuration of their MBLD - never put your MBLD into a configuration by which you have only one method to get control of it.  Having Dashboard but no SSH or having SSH but no Dashboard is a bad situation.  Redundancy of control is very important. 

1 Like

Hi wdlive76

thanks for your answer!

my mainsystem is running under apple os x.

i already tried to get in the Dashboard over Chrome, Chrome Incognito Window… than i switched to windows (windows is running under another HDD). The same problem, it didn’t load.

I tried it from another Computer too.

I also tried to reset the WD by its reset-button on behind of the live duo… The light is green… I see the NAS in the Finder… But when i connect, only the public is available. When i try to login… no account is working (eg. user: admin / pass: admin)

Thanks for the link below your reply, i’ll do this as soon as i get in my wdlive.

Is it possible to do a full debrick with Mac? Or do I need Linux? Would be Windows an alternative?

I just have win+mac.

*Edit* I’ve found a Guide with windows. I’ll give a try. speak later :slight_smile:

These MBL’s aren’t that complicated to fix.  Basically there are four options to use for almost any problem:

  1. Do something in Dashboard

  2. Do something in SSH

  3. Reset button on back

  4. Debrick

Debrick is the ‘nuke’ option in terms of wiping the slate clean and fixing everything 99% of the time. 

Besides the debrick guide on this forum (if you have a Duo, make sure you use the MBLD version not the MBL version) there is also a guide on the wikidot forum.   

ALERT!!! i just looked closely at the firmware version you tried to install… You used MBL firmware, not MBLD firmware.  Do you have a MBLD or a MBL?  Your post says you have a MBLD, but you put this thread in the MBL directory.    Make sure you have the correct firmware for your device.

Here is what happened:  You tried to install the wrong firmware. The MBLD did not accept the wrong firmware. Then you reset the MBLD to factory using the button on the rear of the device; which disabled SSH.   Your MBLD is running exactly the same OS as it was before the factory reset, but now it has no SSH, the passwords have all been reset, and the shares are no longer visible.  You have essentially locked yourself out of the MBLD.  The only option left for you is to debrick via Sata-USB.  Make sure you use the correct firmware.

You probably could have avoided all of this headache by just restarting the apache2 server on the MBLD via SSH.  It is apache2 which runs the Dashboard.  It was probably off from your prior hacking.   That would have given you Dashboard access, then you could have reinstalled firmware from the Dashboard - getting the correct firmware in the process.

1 Like

you’re absolutely right!

i could avoid all of this headache… but i had not enough patience to find in which files i can activate the dashboard again… and so i locked myself out with a firmware/reboot/thing.

i have a mybookliveduo (MBLD).

the problem were modified files/configs that are hiding the dashboard/UI and so on…

in fact of this is 2 years ago and i had help of a programmer… i didn’t knew how to fix this and i tried it on my own.

is this the right guide?

http://community.wd.com/t5/My-Book-Live-Duo/GUIDE-Debrick-a-MyBookLive-DUO/td-p/544860

happy that i’ve an SATA-USB-Adapter. it would be great if ‘we’ can fix this today :smiley:

Thanks for your time! You’re very helpful!

Yes that guide will do the trick. 

I have used this guide

http://mybookworld.wikidot.com/forum/t-607715

in the past and it was also successfull.  Read the comments in this link so you can avoid some of the common problems.

1 Like

this guide was very awesome! I got my UI back!

now it asks for updating the Firmware. should i do this before or after?

http://community.wd.com/t5/My-Book-Live/GUIDE-How-to-write-a-custom-firmware-to-your-MBL/td-p/575563

thanks a lot! very very great! :slight_smile:

You should do the firmware update first thing.  Let it do the automatically.  Then when it reboots itself, you need to turn off auto-updates in teh Dashboard.  The reason is that any future auto-updates will over-write any custom change you make to the OS. Much better for you to be in control of the updates. 

Then make all the changes you need to customize your OS.  There are a lot of interesting things:

enable SSh

Transmission

Featurespacks

No-IP

VPN

ownCloud

Twonky

WebAdmin

You said earlier that you were trying to customize the MBLD for speed. A few things to knock out are media servers if you don’t use them, and the remote access feature  (wd2go) if you don’t use it,

I like to have lots of features installed, but only a few running on start up. That way i have the flexibility of using things, but it doesn’t overload the processor.  YOu can check processor load and temps via FeaturesPacks.

Once you are all done with the customization, then follow the guide for making custom firmware that is resetable by the reset button.

1 Like

hi wdlive,

i’ve updated the firmware and logged in to the dashboard.

my files are gone, but that isn’t a problem, i got them all on another hdd.

i want to use this nas as secure archive (6tb as raid 1… 3tb space)

so i switched the HDD mode to mirroring…

one hdd has the self test passed, the other one failed.

‘Self-Assessment Test: Fail’

Failed Drive
  RAID is still operational, but the faulty drive must be replaced to preserve your data.

that wasn’t before i switched the mode to mirroring…

when i try to run a self test… there are always errors like:

  • 31344 - Error starting diagnostic test: Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance.

or:

  • Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance.

do you know, what i should do? :-/

thanks in advance!

From the error message it seems you have a failed drive.  Do you know which one it is? A or B?    You will have to purchase a new WD Caviar Green 3T drive for it. 

On the off chance that there is something wrong with your OS install due to the firmware upgrade, you can do the debrick again.  This time you can do the debrick from the commandline.  Then when finished, do not upgrade the firmware.  And then check to see if you still have a drive failure.  If so, then it is time for a new drive.  Thankfully you got all the data off it it before it failed completely - very lucky.  Anyways, going forward with it configed RAID, any future drive failures will not have any impact on your data retention.

If the Dashboard tells you that Disk A is the failed disk, then you should use Disk B for the debrick.

isn’t it possible to attach the hdd to my mac pro and format it to test, if the hdd isn’t failed?

it’s the hdd A… the same as i debricked.

i thought to attach the hdd to my computer and format it, put it back to the nas and rebuild the raid… do you think that works?

super uncool if the hdd is really gone… :cry:

You cannot use a Mac or Windows computer to format the disk.  The disk has 4 partition, and each partition is formated in ext3 format. 

Do the debrick again.  Make sure that you have not messed with the partition table in any way.  If that doesn’t solve it, then it becomes a bit more complicated.

The disks have 4 partitions on them.  You do not want to mess with those partitions unless you know how to rebuild them.  So formatting a disk and removing the partitions will be a problem, unless you have one good disk with the partitions and OS running on it to mirror from.  You should try running the MBLD with only disk B in the disk A slot. Remove original disk A and leave it out.  That way you can test if disk B is fully functional with OS installed.  If not, then if you format disk A, you will basically have two blank unformated and unparttitioned disks.  . If disk B is functional, then you can drop disk A into slot B and use the MBLD to format it.  Then you will find out if A needs replacing or not.

It is possible to start with a completely blank disk and build the partition table and then install the OS.  There are guides how to do it - because that is what people with teh single disk MBL have to do in event of disk faliure.

By the way, your files should not be gone. It is just that the shares are not visible. In Dashboard you need to set up the shares with the same names as before, then all the data will be visible.  This might just be the source of your fail/error messages.  The Guide tells you to do this step, so i thought you had done it.

hi, thanks for your reply,

i did the guide 'til this:

Check Storage Settings in your dashboard to get a % complete on the array build

Once completed, a reboot should get both drives to display GOOD in the MBLD dashboard

i had always a spanned nas, everything was ok after the firmware update… as i changed it to raid1, the error showed up.

in the MBLD, i took out disk A and replaced the Slot with disk B… i turned it on and following message in the dashboard:

Initializing device. Please Wait…

Under Storage, Slot A has passed the test, slot b is marked as failed drive…

the same message, when i put drive A into the empty Slot B…

Diagnostic Test Result:

  • Drive B Failed diagnostic test.
  • Navigate to Support and create a system report to troubleshoot or obtain automated customer support from WD.

How can i Format the disk B by MBLD?

ah, i tried this with creating shares with the old names… but it created a share that had 5,97TB free space. i also connected over sftp and the folders where the data should be were empty…

i don’t know what i did wrong… 

thanks a lot!

It looks like your one disk is got some problems. There is a very good chance it will need to be replaced.  But, you are correct to want to try to format it and see if that repairs it.  Since we don’t know where the problems are in the disk - which partitions have the problems - and since you have a functioning disk B with the OS on it, we can strip the disk A down to a blank disk without partitions.  

The best way to do this is to attach the disk to your computer running linux and use some linux commands to first repartition it into one big partition. 

Alternatively, you could connect the failed disk via USB to the USB port on the back of the MBLD.  Connect as external storage. Then you could use this guide http://community.wd.com/t5/My-Book-Live-Duo/GUIDE-Attaching-external-storage-to-MBLD/td-p/865319

Once you have the disk into a blank condition, then you can put into to the MBLD and let the MBLD partition it into 4 partitions and then format it.  Basically you will be following the instruction in teh MBLD users manual on how to replace a failed disk.

hello,

i’m sitting here with my MBLD and a SATA->USB adapter.

when i plug the disk A to the USB of MBLD, using ssh and parted… following message is showing up:

(parted) print all                                                        

Model: ATA WDC WD30EZRX-00M (scsi)

Disk /dev/sda: 3001GB

Sector size (logical/physical): 512B/512B

Partition Table: gpt

Number  Start   End     Size    File system     Name     Flags

3      15.7MB  528MB   513MB   linux-swap(v1)  primary  raid

1      528MB   2576MB  2048MB  ext3            primary  raid

2      2576MB  4624MB  2048MB  ext3            primary  raid

4      4624MB  3001GB  2996GB  ext4            primary  raid

Model: Unknown (unknown)

Disk /dev/md1: 2048MB

Sector size (logical/physical): 512B/512B

Partition Table: loop

Number  Start  End     Size    File system  Flags

1      0.00B  2048MB  2048MB  ext3

Model: Unknown (unknown)

Disk /dev/md2: 513MB

Sector size (logical/physical): 512B/512B

Partition Table: loop

Number  Start  End    Size   File system     Flags

1      0.00B  513MB  513MB  linux-swap(v1)

Error: partition length of 5851500272 sectors exceeds the                 

loop-partition-table-imposed maximum of -4294967296

Error: Can’t have a partition outside the disk!                           

(parted)

isn’t it possible, that i do the blank formatting over the CD-ROM+USB-Stick with gparted? I’m not sure about the Terminal message above… i think the only 3TB disk that it is showing, is the internal HDD… shouldn’t there be twice HDD’s?

Do the format with your computer running Linux.  There are alot of tutorials about how to do this.  Remember that you must remove the partitions first.

Since you are dong a last ditch effort before committing to buy a new disk, you can try whatever you want; format with Windows, Mac, whatever. The point it just to get the disk into an initial state - like it would come from the factory. 

yeah! i did it over the ssh command line :slight_smile:

at the moment, the MBLD is rebuilding the raid0

both hdd’s have the test passed… i hope it will work with the rebuild.

there are no files on the nas, so it shouldn’t take too long… or maybe it does take long… i don’t know… :slight_smile:

1% … i’ll keep you posted if everything has worked or not! THANKS A LOT for you help!

*edit* drive fail again.

i don’t really understand this.

*edit2*

i think i’m gonna format it with my mac in a single partition first and after this step, i try to format it again with MBLD into ext4.

*edit3*

what really makes me headache… the HDD attached to my mac is showing, that the capacity is 802gb… same as in the terminal/ssh before. the disk is a 3TB WD Caviar Green… why are just 802gb shown? 

your Mac is probably just showing only one of the partitions.  You need to remove the partitions first.

Use the LInux PC to knock out the partitions.

You might want to clone the partitions of your working disk. Just write down the specs from above, and then using gparted or something similar create the same sized partitions with the same format strucutres as on the working disk.

Also, before settting it to RAID1, try the other modes to see if they also give a disk failure error.

i just looked the output from parted on my MBLD

Mine lists the two internal disks. then it has the similar things as your (but no error message at the end)

Model: ATA WDC WD20EARX-00P (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name     Flags
 3      15.7MB  528MB   513MB   linux-swap(v1)  primary  raid
 1      528MB   2576MB  2048MB  ext3            primary  raid
 2      2576MB  4624MB  2048MB  ext3            primary  raid
 4      4624MB  2000GB  1996GB  ext4            primary  raid

Model: ATA WDC WD20EARX-00P (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name     Flags
 3      15.7MB  528MB   513MB   linux-swap(v1)  primary  raid
 1      528MB   2576MB  2048MB  ext3            primary  raid
 2      2576MB  4624MB  2048MB  ext3            primary  raid
 4      4624MB  2000GB  1996GB  ext4            primary  raid

Model: Unknown (unknown)
Disk /dev/md1: 2048MB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End     Size    File system  Flags
 1      0.00B  2048MB  2048MB  ext3

Model: Unknown (unknown)
Disk /dev/md2: 513MB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End    Size   File system     Flags
 1      0.00B  513MB  513MB  linux-swap(v1)

Model: Unknown (unknown)
Disk /dev/md3: 1996GB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End     Size    File system  Flags
 1      0.00B  1996GB  1996GB  ext4

Did you try to run parted -> print all with only one disk in the MBLD?  It would be strange if you got an error with just the good disk installed.

Thinking about it now, it looks like your data partition (the 4th partition) is still being treated as linear mode (not RAID1). that is why you get an error from Print ALL.  Try doing things on teh MBL wihout putting it into RAID1 mode. For some reason the MBLD isn’t going into RAID1 properly.  Maybe you need to reinstall firmware.   Though the most likely reason that it is not going into RAID1 properly is because you have a failed disk that needs replacing.

Maybe, with both disks installed and not in RAID1 mode,  try running a full test using the diagnositic utility listed in teh Dashboard.

1 Like

Sadly, i think to buy a new disk is the way to go. Maybe, i gonna trash this nas. It was pain from the first day i bought it.

The only thing i want, was a fast storage for my backups. :-/

Before i took out the HDD, it was possible to load plenty of data out of the NAS without problems.

So i can’t believe, that the HDD is really gone.

The last Test i’m gonna do:

I’ll connect the HDD into a bay in my MacPro and have a look, if the HDD still showing just around 800gb as here over SATA-USB:

than i think something is wrong with this HDD. at the moment, i think the problem is the SATA->USB-Adapter that maybe doesn’t support 3TB HDD’s.

i’d run a factory reset in the nas, everything was resetted and without a problem. the diagnostic test message was, that there is a failure in drive B. (without raid0)

i keep you posted…

Try the Full Diagnostic test from teh Dashboard. it might tell you where exactly the failure is coming from.

This NAS is a great system if you config it properly.  If you have a bad disk, that’s a fairly cheap fix instead of getting another NAS.   With this NAS you can set it up to run ownCloud so that it auto-syncs with your computer (remote or local) whenever there is a change on teh computer or the NAS files. 

by the way, there is a report from a company that runs alot of disks abotu which type of disks were least prone to failure.  Sadly the 3Tb disks fail with higher frequency than 2tb or 4tb.  Can’t remember where the link on teh web is.   So you might even consider buying 2 x 4Tb disks instead of the 3Tb unit.