No Browser access due to java.. MAC Pro Safari and Chrome

I get java warning and errors on my Mac Pro using Safari and Chromeand itwill not show my shares however Firefox does work. The warning appears in Forefox as well and that I must run in unrestricted mode which will not be allowed in the future… It has been doing this for some time.

Is there a fix to this or coming soon as I do not always have the luxury to use the desktop app or the browser of my choice … especially at school.

I have seen posts claiming this has been fixed and the thread was closed. But I have the latest and greatest of everything and the the problem contnues and is very real.

Appreciate any feedback or advice.

Thank you!

Maybe you should try contacting support for this issue.

Have you tried WD Cloud for desktop. Haven’t tried the Mac version but the windows version works quite well.

With the duo, you may need to use an activation code. I have 2 duo’s and 2 EX2’s. For some reason I had to use a code for one of the duo’s but not the other.

I do use WD Cloud for desktop and it works fine. But when accessing  my drive from a client’s machine or using a school or public computer this is not always an option.

Screen Shot 2014-05-02 at 10.59.48 AM.png Screen Shot 2014-05-02 at 11.00.37 AM.png

I did receive a response and was basically that it’s a browser issue and not Western Digital’s problem.

“In regards to your inquiry, we are sorry to hear this is happening. This is something that we do not manage, if it is working on Firefox it may be an issue with Java with the other browsers. The fact that it works with Firefox, shows that it is an issue with the browser. We apologize for the inconveniences this may cause you.”

But again this is an issue across all browsers and warns that we will not be able to run in “unsigned mode” in future releases on ALL browsers. (see the Screenshots I posted in this thread)

I have just got this product and to say that I have not seen garbage like this in a long time is an understatement.  Could this product be anymore complicated and stupid for what is in essence a remote hard disk.  I’m really upset that I didn’t buy the Apple Airport now.  Cannot access via Safari due to Java blocking.  No guidance on how to sort it and the forum thread just stops with no solution.  Trying to get support required a full log, which was tedious.  

This is a **bleep** product at an expensive price.

Also for ease of use there is little information on securing files and locking the server or restricting access.  I time machined the mac to the device and it is seen everywhere so in fact everyone can pull down the time machine file and copy it.  This is poor, disconnected the server until I can figure out how to lock it.  

Cheers, great work guys.  Really thinking about taking this **bleep** back to the shops.