No, .bin : (dot)bin folder allowed?

This seems hard to search for so I apologize if this is answered somewhere else.

I’m guessing there is something special about ‘.bin’ folders. I was trying to copy some stuff to my MyCloud and was getting errors. I tracked it down to a portable app that had (dot)bin folders that could not be created. I tried creating the folder. I could make a new folder, but couldn’t name it ‘.bin’

Is there a way to fix that or get around it? Or is that a can’t be done thing?

You should try contacting WD’s Technical Support about this for live assistance and troubleshooting.

To Contact WD for Technical Support

So, I just bought a new WD NAS and I have the same issue. And I’m already pissed right now…
The issue is caused by /etc/samba/smb.conf containing the line

veto files = /:2eDS_Store/.bin/Network Trash Folder/.systemfile/lost+found/Nas_Prog/mirrored/uploaded/.wdmc/.AppleDouble/

You can edit that file via SSH (if you enable SSH) and also apply it by restarting smb via executing smb restart, but the changes will be overwritten whenever I restart the NAS or change any Samba related configuration in the Webinterface.

This is not acceptable for a professional NAS.

Any ideas how to solve this?

Related topics: