No audio when it is connected to hdmi or composite cable

I have purchased a WD TV Live and My Book Live from Singapore and using it in INDIA. When I checked it Singapore and initial check at CHENNAI worked well. But now I am not getting any AUDIO output for any formats from the WD TV Live unit. Can anyone help me to solve the problem? I doubt it may be any CONFIGURATION problem in AUDIO output menu, Initially I configured well and it was working, but now it is not. Any way I wait for your advise. 

Hello rajag, you might have the audio output setup to “Digital without HDMI audio”, try changing it to “Stereo” or “Digital”. 

If the problem continues, try pressing the reset button. Check page 7 and 129 of the manual for more information.


1 Like

Hi Itchigo,

Thanks for your response. My audio configuration was- audio out put port in ’ Digital pass-Through via HDMI Only ’ then Manual Set up (Auto set up is not supported in my Samsung Series 6 Smart TV) So I have selected one by one ’ capable receivers ’ and tried no Audio for all selections. After wards done reset the unit and repeated the same, no change. Is there is any other configurations apart from these?

Please share your experience. What to do??



Hi again, check if you have the latest firmware installed, if you do, you can roll back to a previous firmware version. If the problem continues, I recommend you to contact tech support.

How to roll back the firmware on a WD TV Live HD Media Player or WD TV Live Plus HD Media Player 

Tech Support

Edit: Fixed link for the rollback KB article.

1 Like

Hi Ichigen,

Thanks. As you said before updating the firmwire it was working alright. Now I have the latest version 1.16.13.  May be this version making problem for my WD TV live. I have downloaded the rollback firmware 1.06.15 version and followed the steps, but there is no popup for the Sync the USB or any New firmware menu in Home. So I couldn’t install the rollback firmware version. I have contacted the local Tech guy and they advised me to go for RMA.


rajag, everything here is very confusing.   You say you are running 1.16.13 firmware.   The Live / Live Plus don’t have that firmware (and that’s the section you posted in.)

You also said you downloaded rollback firmware 1.06.15.    That’s for the Live HD (Gen 1), so of course that won’t work if you have a Live Hub or Live Gen3 (SMP.)

Ichigo provided you the manual for the Live Gen 1 / Live Plus, but provided the firmware rollback instruction for the Live Hub / Live Gen 3. 

Which product do you have?  Please reply with the MODEL NUMBER, not a name.