No Audio on Netflix?

Just installed wireless dongle on WDTV HD Plus and updated firm ware to 1.04. Everything seems fine except there is no audio for Netflix. Files on USB drive, youtube, etc. works fine with audio, only netflix is muted. Anyone had the same problem?

Since one of the last fw updates, I’ve had issues with netflix sound.  When I first play a selection, there is no sound, but when I stop and restart it, the sound works…for the most part, that is.  I randomly lose sound for a few seconds here and there through the shows.  Quite annoying :\

Same here. Seems every time I first start Netflix the first movie never has sound. Have to restart to get it back. I’ve also had one movie that played the sound effects track, but not the speech track. I heard footsteps, doors closing, car horns, etc. but the characters just moved their lips without saying anything. Weird. Didn’t have any trouble until I did two firmware updates in a row to bring it to the current version. Hope this gets fixed soon.

Could this be WD issue or Netflix issue?

I’d say WD. I never had this trouble until I updated the firmware. Anyone from WD working on this?

We are having this problem as of 1-11-11.  Hopefully it will be resolved through a firmware update soon.

I have had this happen a few times since the last firmware update. I select Netflix, pick a movie from the queue and it starts playing fine with NO sound. I back out and check all of the settings and they are OK. I try Netflix a few more times with the same result - no sound. To fix it, I have to power down the WD box, let it boot up, and then the sound works with Netflix.

Others have reported this same problem in the long threads on the new firmware release. I guess that this is just another problem to add to the long list of problems that the last 2 firmware updates introduced.

Any Fix for this - I can not get audio at all - I can reboot the box, stil  no sound on NetFlix.  I can stop/ start netflix shows etc… and still no Audio!  This is extremely frusterating.  I get audio off my shares, pandora, you tube etc…  Anyone know the reason behind this?


Does Western Digital respond to or fix ANY problems? I have called and e mailed about no audio over digital out on Netflix for several months and get NO RESPONSE! Honestly is WD is licensed to used Netflix HD than why can’t they fix this problem??? 

Thank You,


JTaylor, You can downgrade the firmware to 1.03.49 and the problem will most likely go away. This no sound with netflix problem is one of the reasons that I am using 1.03.49.

Yup. I’m not upgrading any more…I’m actually using the prior version (14.03?) with no issues. There she’ll shall stay until I replace this device.