No audio in MKV files with A_DTS track


#1

Here is the video info.

(MKVInfo) + EBML head
(MKVInfo) |+ Doc type: matroska
(MKVInfo) |+ Doc type version: 2
(MKVInfo) |+ Doc type read version: 2
(MKVInfo) + Segment, size 3218087976
(MKVInfo) |+ Seek head
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x15 0x49 0xa9 0x66 (KaxInfo)
(MKVInfo) |  + Seek position: 4099
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x16 0x54 0xae 0x6b (KaxTracks)
(MKVInfo) |  + Seek position: 4250
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x1c 0x53 0xbb 0x6b (KaxCues)
(MKVInfo) |  + Seek position: 3217876601
(MKVInfo) |+ EbmlVoid (size: 4044)
(MKVInfo) |+ Segment information
(MKVInfo) | + Timecode scale: 1000000
(MKVInfo) | + Muxing application: libebml v0.7.9 + libmatroska v0.8.1
(MKVInfo) | + Writing application: mkvmerge v3.2.0 (‘Beginnings’) built on Feb 12 2010 16:46:17
(MKVInfo) | + Duration: 10115.375s (02:48:35.375)
(MKVInfo) | + Date: Thu Jun 10 12:16:22 2010 UTC
(MKVInfo) | + Segment UID: 0xb1 0x06 0x28 0xfd 0x60 0x43 0x98 0x72 0x96 0x2a 0x2b 0x89 0xab 0xdf 0x69 0x0e
(MKVInfo) |+ Segment tracks
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 1
(MKVInfo) |  + Track UID: 1
(MKVInfo) |  + Track type: video
(MKVInfo) |  + Enabled: 1
(MKVInfo) |  + Default flag: 0
(MKVInfo) |  + Forced flag: 0
(MKVInfo) |  + Lacing flag: 0
(MKVInfo) |  + MinCache: 1
(MKVInfo) |  + Timecode scale: 1
(MKVInfo) |  + Max BlockAddition ID: 0
(MKVInfo) |  + Codec ID: V_MPEG4/ISO/AVC
(MKVInfo) |  + Codec decode all: 1
(MKVInfo) |  + CodecPrivate, length 53
(MKVInfo) |  + Default duration: 41.667ms (24.000 fps for a video track)
(MKVInfo) |  + Language: eng
(MKVInfo) |  + Video track
(MKVInfo) |   + Pixel width: 1280
(MKVInfo) |   + Pixel height: 544
(MKVInfo) |   + Interlaced: 0
(MKVInfo) |   + Display width: 40
(MKVInfo) |   + Display height: 17
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 2
(MKVInfo) |  + Track UID: 716596395
(MKVInfo) |  + Track type: audio
(MKVInfo) |  + Enabled: 1
(MKVInfo) |  + Default flag: 1
(MKVInfo) |  + Forced flag: 0
(MKVInfo) |  + Lacing flag: 1
(MKVInfo) |  + MinCache: 0
(MKVInfo) |  + Timecode scale: 1
(MKVInfo) |  + Max BlockAddition ID: 0
(MKVInfo) |  + Codec ID: A_DTS
(MKVInfo) |  + Codec decode all: 1
(MKVInfo) |  + Language: hin
(MKVInfo) |  + Audio track
(MKVInfo) |   + Sampling frequency: 48000
(MKVInfo) |   + Channels: 6
(MKVInfo) |+ EbmlVoid (size: 1024)
(MKVInfo) |+ Cluster

I looked up the eariler posts about MKVMERGE 4.1 compressing audio tracks and tried to set compression to NONE but it didn’t seem to fix the audio.


#2

Welcome to the forums.

How are you playing your audio?  Do you have “Stereo” or “DIgital” selected in the audio/video properties of the Live, and are you using HDMI direct to your TV or do you go through a receiver (explain exactly how your system is setup).


#3

Thank you.

Setting the audio from digital to Stereo worked.  Can you tell me why, if you pardon my ignorance?

The setup is a HDMI connection from my WD TV Live to my  TV.


#4

“Digital” means to pass through the DTS or AC3 track to be decoded by the output device.  Most TVs cannot decode DTS or AC3 (since that’s primarily a surround sound function) so you need to use “Stereo” and let the Live decode it for you.

When/if you decide you want surround sound you will take the output of the Live (either via Optical cable or, if the receiver supports it, HDMI) and change back to “Digital”.  The receiver will decode the DTS/AC3 track, and then your TV will display the image (from the outputs of the receiver if it has HDMI, or you will connect the HDMI directly to your TV and the optical to the receiver).