No Audio From Services - Out of the Blue

Been using my WD TV Live in its currret setup for years with no issues.  Today, out of the blue, no sound / audio when I use services like Pandora, YouTube, TunedIn etc.  Audio from streaming movies from my network no problem. 

No updates to firmware occurred, no changes in setup.  Using optical out.  Tried disconnecting power for 30 seconds.  No luck.  No I have not tried device reset because I don’t want to reconnect network etc when everything else has been working for ever.  I suppose that’s my next try but wondering if anyone else has experienced this.

OK - did the device reset. After a painful hour of trying to get everything set up again including network shares… no luck.  Still no audio from services.

Any suggestions before I pull out my sledge hammer?

Hi there,

Try to do a rollback on the unit see if this helps you out. Here is a link that will help you with the rollback procedure:

Hope this helps.  

I tried this, now my system is completed bricked… it won’t boot.  Comes to a screen with a giant red circle and a cross through it.  Says Please Insert USB Drive with Firmware to Recover your WD TV.

I tried inserting a USB drive with firmware at the root (tried different versions too) and it simply won’t read anything off the USB drive.  I tried hard reset using the paperclip.  Nothing.  Been on two support calls with WD… nothing.

OK - I had to put the most recent fw on a USB drive and now it is installing the most recent back.  After this occurs is I still have a problem I’ll try rolling back again.