No Audio for DTS-MA videos. Help Please

Hi everyone

I just bought a new HD TV media player (WDBYMN0000NBK) and updated with the latest firmware (1.02.17). connected to AVR (Harman Kardon BDS 570) through HDMI cable. But no audio can be heard. DTS audio files play fine but NOT DTS-MA files

My previous player (NOT WD) had no problem playing those video files (DTS-MA and DTS)

I tried both auto-detect as well as manual setup (for the Audio output), with no luck

Anyone knows how to fix the problem. please?

Welcome to the WD Community.

Have you tried resetting the unit and testing that again?

Make sure that the files that you are trying to play are fully supported.
See if the following link helps.
http://support.wdc.com/KnowledgeBase/answer.aspx?ID=2698#live

Thank you for taking the time to reply

My files are compatible with WD

I did a lot of Internet search. It seems that the WD has a licensure problem with DTS MA pass through.

I followed the one recommendation of converting the DTS MA to DTS using “mkvmaker”. The results are successive . But this is cumbersome approach because I have many movies with DTS MA audio.

I hope WD can find a way to solve this problem because many movies recently come with this HD audio format (DTS MA).

That sounds odd. My WD LIVE TV plays DTS MA fine (connected to an Okyo surround receiver) with HDMI.

Did you remember to set this setting
“Digital Pass Through via HDMI Only” in your WD LIVE TV? WD LIVE TV can’t deconde dts ma, that is a job for your receiver.

Thanks for replying

My unit is WD TV media player and not (WD LIVE TV). I am not sure if that has anything to do with it. And, yes, I have set the Audi to “Digital Pass through via HDMI Only”. But no luck

btw, my AVR (Harman Kardon BDS 570) is supposed to decode DTS-HD MA (as per the manufacturer specifications). So, it seems that the problem lies in the WD TV player itself

have you tried setting it up manually ? (Page 180 user guide)

eg. select “Dolby TrueHD capable receiver”


note: WD added DTS-MA support but forgot to update the labels in the Manual Setup menu

discussion here: Dts hd ma

I tried that one too. Still no audio for DTS-MA files