No audio followed by "unsupported format"?!

Hi all,

I’m having some issues and I really hope you can help! What started out as a supreme experience turned into a very frustrating one.

I recently bought the WD TV Live Streamer, and started out by upgrading to the latest firmware. I tested it by connecting my My Passport 320 GB and played back a bunch of movies. It all worked so far, mkv, mp4, avi etc.

Then I started changing some stuff, like audio output from stereo to dolby and dts, adding a lot of movie content like backdrops and thumbnails and so on. Furthermore I was prompted with yet another firmware update which I installed.

All of a sudden problems with the sound started occurring. When playing back any movie the video would show but no audio. After this observation, trying to play any video results in a message saying something like “Unsupported format, please check the manual for supported formats”. This error message obviously doesn’t make sense as all of the video formats I have are stated in the manual (both containers and codecs), and secondly they have all played back fine on the WD TV earlier.

In order to find a solution I’ve tried different things. Restarting the device, removing the power, resetting the device (for some reason a factory reset results in the newest firmware, so I’m unable to do a full factory reset), changing the HDMI cable, connecting the WD TV to my Denon receiver instead of my Samsung TV. Sometimes it helps but pretty soon the problem is there again. (Also, it seems to act differently if you stop a movie playing using the stop button on the remote verses the back button on the remote, but I’m not sure about this). 

Anyway, I could really use some help resolving these issues!

Thanks :slight_smile:

If you change your audio setting output back to Stereo, are you able to play your movies?

Nope, still same issues… But I’m kind of narrowing in on MP4’s as the source of the problem.

I found this description in another thread matching my problems:

most MP4’s use AAC codec for audio the WDTV can’t play AAC 5.1 or greater the codec is no supported i’ve used mkvtoolnix 4.4 to re-encode to a mkv then use the popcornhour audio converter to convert the audio to AC3 the popcorn hour converter won’t work with versions higher than 4.4 you can also use handbrake

Yeah I know i could just convert the audio, but one of the reasons I bought this unit was to avoid having to convert my media files. Furthermore as I understand from other threads, the WDTV should just downmix the AAC 5.1 to stereo so I’m still able to get a soundtrack though not in surround.

The weird thing is though, that it did play at some point, so it cannot be altogether unsupported. But even if it is unsupported it shouldn’t affect playing the rest of the compatible formats on the drive. As it is now, if you attempt to play that certain MP4 the device will go in a mode where it refuses to play anything until you have restarted it. This is not acceptable and really something WD should look into!