No access to the NAS after upgrading to OS 5, even after resets

It seems you can add me to the list of people who have big problems after the latest big update…

I have a MyCloudEX2Ultra, and I used accessing it with a PC and an external Mede8er Multimedia player, without any problem before the update.
So I did the update 5 days ago, and after that, I couldn’t access the files from the multimedia player. It uses Ethernet access, the NAS was visible, but when I tried to open the folders there was a user/pass prompt, and no combination worked (I don’t have a password on my PC, there were no users registered in the config, only admin access ; I tried, admin/password, admin/blank password, etc., nothing worked). But I was still able to access the files normally with my PC, the folders were mapped, everything was working fine on my PC, even remote access.
So I looked here for similar topics, like this one, and I decided to try the reset method.
I tried this method, Option A, still no access to the NAS from the player (same logon error), but I could at least access the files from the PC; then I tried the Option B, and I lost every connection… the NAS is not visible anymore from the PC, the mapped folders can’t be accessed, the remote access with the old direct IP doesn’t work, and the http://mycloudex2ultra URL redirects me to the configuration of my Wi-Fi extender… The NAS also disappeared from the network on my PC.
If I open the config of the router, the NAS appears, but it has no IP, only a MAC address…

So I have 2 quesitons :

  • How can I restore the access to my NAS, so I can configure it again from my PC ??
  • Why was there a logon issue when trying to access the NAS, since there were no password configured anywhere ???

Thanks for your help

If it’s indexing i noticed mine continually dropping off the network randomly and just not being available. If you power cycle it it should let you in to turn off cloud access maybe and then it will stay up …maybe …

The problem was that I had no access to the config at all, so I couldn’t even deactivate cloud access…
It seems there were a conflict with Wi-Fi extender, so I turned it off and rebooted the router and the NAS reappeared in the network and the files are accessible again on my PC.
So I entered the config, for the first time after the reboot, so I guess the setup was all restored by default, I set up a new password to the admin login and changed nothing elese (I didn’t activate cloud access this time, just in case).
But I tried again on my multimedia player, it still asks for a login/pass to access the file, while Windows 10 opens the files without…

Did I miss something to be able to access the files without password? Or is there a default login/pass combination I should use???

What protocol does your multimedia player use to communicate with your NAS?

I can’t say exactly, I just open the network Browser, enter WORKGROUP\MyCloudEX2Ultra and then it asks for a password.
I can just say it’s not SAMBA since it’s deactivated in the Player settings, but I don’t really know what protocol exactly…

OK, I think the problem is partially solved.
With latest update, only SMB3 protocol is activated, and it seems that my device required SMB1 protocol. So I activated all SMB protocols (1 to 3), and now it works again!
But it’s only partially solved, because I still don’t know what were the expected login/pass asked since there were none configured…

@Ahmed84 Sounds like your media player requires NTLMv1 and My Cloud OS 5 firmware 5.04.114 only supports NTLMv2. NTLMv1 will be a selectable option in the next firmware release so that may resolve your issue. If you comfortable with SSH, you can try the Sonos workaround posted here, Sonos Local Music Library (SMB) no longer works with OS 5

Thanks for the tip! Since my player works again, I’ll try to keep the settings as they are, but if I need to I’ll try this other method.
But I still think it’s a shame that the new update seems to brings more problems than it solves… I hope the next one that fixes them should not bring new ones!