No Access to shares after updating to 5.04.114

I only use myCloud Ex2 in a private network. after updating to FW5.04.114 I still can open the setup via webbrowser, but I don`t have any access to the shares that I have mounted to several PCs or even the TV.
I have NOT installed any apps after the update, because I only need the fileshare. Trying to mount with a PC says that the server (WD Media my Cloud) already has its maximum of clients ???

i have the exact same issue and i’m getting no resonse from WD Support. We’ve tried resetting, rebooting and nothing seems to help.
anyone that has had this issue with a resolution?

I have a WD EX4100 NAS and just recently updated it to firmware 5.04.114. After that, my Sonos couldn’t access my NAS music library, so I had to make the share Public. I think the issue is on the NAS side given the recent firmware update. This had worked fine before the upgrade for quite a while.

The only way it worked for me was to make the share public and enter nothing in the Name and Password fields in Sonos - somehow it is not getting the user name correct. Other Sonos users report the same issue and it was affecting Windows access to the shares as well. Something got broken in this update.

@bullmoon, this Kb article may help you: