No access to MyBookLive

I recently got a new Asus router and ever since I haven’t been able to access my MyBookLive. There is a solid green light on the front. Looking on the router UI, the MyBookLive doesn’t appear in the connected devices. I have tried different Ethernet cables and still not appearing.

I really need to access the files on the MyBookLive so I need to find a fix that doesn’t remove my files.


When you changed routers, did you configure it so the IP subnet for your home network is the same as it was before?


Both router subnets are

ChecK the manual and do the reset which only resets the admin password and removes the static IP.
Then go to your router’s DHCP lease table and get the new IP for MBL

Done that and still not appearing on the router.

That’s the subnet MASK, not the subnet. The subnet is something like or whatever.

Sorry. My old router was and my new router is

My old router was supplied via the ISP and has been put in modem mode. My new router is plugged into the back of my old router.

Should I change the subnet from 192.168.1 to 192.168.0?

If you executed the reset correctly, the MBL should be back on DHCP, just keep whatever your router has.
But if you still cannot find it even under DHCP, you might not be looking into the correct router for its DHCP clients and your machine might also not be connecting to the same router.

my .02, plug MBL and your system on the same router, see if you can find it. Or remove one of the routers, unless you need both for some reason.

The MyBookLive is directly plugged into the new router. My computer is also directly plugged into the new router. I still need the old router as my that’s how the internet comes from my ISP.


Few days ago I lost connection to Mybooklive, things are really odd though…

  • I can connect to the dashboard via a browser and IP address

  • I can see the device, in my devices, see the properties

  • I can access it like a media server and access all of my videos, pictures, music files

  • I cannot for the life of me map the drive or access document folders. It says path not found… etc., etc., figured out that its missing network protocols.

  • more digging led me to believe this is actually an issue due to the latest MS Windows 10 update.

Is anyone else experiencing anything like this… spent 2 hours with windows help chat… nothing… :frowning:

Should I try changing the subnet from 192.168.1 to 192.168.0?

It’s worth a try – just ensure you change not only the router, but anything else on your network that’s not using DHCP…


I didn’t change the subnet.

I found the MAC Address of the MyBookLive on my old router and was able to set-up a static IP on the new router.

The MyBookLive then appeared on the network for one day and then disappeared again.

Go back to your old setup or in a few words, keep it simple for testing purposes. Even if you have to be without internet, which is not needed on this case. Just see if you can get it visible on your LAN.

I have a feeling you are having some issue with both routers in your network. One of them has to be setup to be just a switch (no LAN/DHCP/No DNS server/etc).

For testing purposes, I switched back to the old router and the MyBookLive was visible.

I have now switched back to my new setup. The old router (Virgin Media Super Hub 2) is in modem mode and connects to my new ASUS router. The MyBookLive is connected to the ASUS router. At the moment it is visible on the network but will probably disappear later today.