No access to mybook live

I have no more access to my mybook live.
The green led is on and the disk is working - it’s the typical rattling sound…

The situation: I can ping the device and it answers to the ping. I can see the correct mac-address in my arp-cache. Checked with nmap I see that the only open port is 111 (RPC). That means I can not access it via browser. Neither http (80) nor https (443) is reachable.
And I cannot reset the device to factory default. I always has the same static ip. I tried the 4-second reset as well as the 40-second reset.

A call to WD-support was really disappointing. The lady had no knowledge about what I was talking about (ping, arp, mac-address…).

Does anybody has an idea what to try?



If you did the reset, check the IP address the MBL got in your router’s DHCP table. Use that IP to connect via http in browser.

After the “not-working-reset” the MBL still has the same/former IP address.
It does not contact the DHCP server for an ip address (no DHCPDISCOVER).
The reset is not working…

How do you know it has the same IP? Yes, DHCP might give you the same IP sometimes, it is not a static IP though, still DHCP. Just wondering how you are doing it. Provide as much info as possible.

Better yet, unplug the ethernet cable for MBL, refresh the DHCP router’s table and see if it is gone (or delete it from it, most routers allow it), which it should be. It should not appear again until you plug it back in. Once it appears again, then that should be your IP.

It has the same Ip because I still can ping it…
I have the MBL and a PC on the same switch. On the PC runs Wireshark to sniff network trafic and a DHCP server. When I now Boot the MBL there should be DHCP trafic from the source of the MBL. But there is no DHCPDiscover Sent from MBL. Pushen the reset button should change the device from static IP into DHCP Mode.
But pushing the button has no effect —> reset does not work.
How can I force MBL to get back to factory settings? As I said, neither the 4-second nor the 40-second method works.

You are over-engineering it with wireshark, stick to the basic, this is not a difficult issue at all.
Just because you can ping it does not mean it is the MBL that has that IP. This is the part you need to debug.
If you:

  • Have a green LED, it is connected to the LAN
  • Go to whoever is your DCHP server, and check its lease table. Try my suggestions, off and on to see if the lease table updates. Again, this is the part you need to debug… who has what IP…

Reset is the 4 or 40 second method, those work. Specially if you have a green LED already.
You mentioned you have a DCHP server? Possible you might have two? the router and another server? Did you disable your router’s DHCP server?

FYI… With wireshark, you are only sniffing the traffic in/out of the particular device where you have it running. Unless you have a monitor port on your switch/router and forwarding all the traffic to this machine, which is not possible on most home devices.
For you, in order to see all traffic, would have to capture all traffic on switch and/or gateway device.

I’m amazed at the misinformation in this topic.’

Ping is one of the most basic network debugging tools. If you can ping an IP address then THAT is what the IP address of a device is. The correct MAC in the arp-cache indicates that device is the MBL. There is no DHCP because the device has been set to a static IP address and button pushing does nothing, indicating that boot-up is getting to green light but for some unknown reason the button is not being monitored. No amount of button pushing is going to get you anything. Further discussion of DHCP indicates whoever thinks that relevant is not paying attention. It’s not going to go from static IP address setting back to DHCP unless a reset works, and OP has proved that it doesn’t work.

Ports 80/443 not open indicates Apache service is not running (and no control panel). Inability to connect to shares indicates Samba service is not running. EVERY MBL owner should enable SSH just for emergencies even if they never intend to use it. (WD should have defaulted this service ON.) But if your other ports are closed my guess is that even if you had enabled SSH it wouldn’t have helped and would probably be not open.

Your comment about “typical rattling sound…” has me bothered. You should hear nothing but a humming sound when you put your ear near the grille. HDDs in good health do not rattle.

So let’s have a little bit of reality here. Irrespective of the green light your device is effectively bricked. You have a good chance your data is still valid (depending on what precipitated its becoming inoperable). Between ping response at the static address you set and presence of the MAC address in arp cache indicates connectivity at the basic Ethernet level is established. This is the bad part: there are no open ports that will give you any access and the button is not being monitored. Apache and Samba are not running. If you had enabled SSH it probably wouldn’t be running either. Effectively you have no way to interact with the MBL - effectively it is bricked.

At this point I see no alternative except to remove the HDD and attach it to some other device. Ideally you have a Linux desktop, second choice is a Windows PC. If Linux there are various tools that may give you more information (fdisk, gdisk, parted). You could mount the EXT3 partitions (your MBL OS) and depending on your setup (if it accepts GPT partitions) even mount the EXT4 shares partition. – There are various Windows tools mentioned elsewhere in this forum including R-Linux that allow some accesss from Windows – And finally you can create a live Linux CD and boot from that even if your PC is Windows, and gain full access to the HDD.

At this time I see a necessity to remove the HDD and gain access by one of the methods above. However I think even an expert would have problems figuring out what is wrong just by analyzing what they see, unless it is something gross like missing/corrupted partitions. (I fixed one brick because I remembered I mistakenly edited the fstab file on the wrong network device, so I was able to go in and un-edit it.) But you don’t know how you got here.

In closing I see two possibilities. Your rattling sound indicates an HDD failure to me if you are accurately describing the sound. If so, the HDD is still partially working and it may be possible to recover data before replacing the HDD. Depending on the size of HDD and apparently it’s not a DUO, you may be better off to just toss it and buy a new MBL since a replacement HDD may cost almost as much or more than a new MBL.

If your HDD is healthy, then I see the obvious conclusion that you will have to follow one of the debricking procedures. In these procedures you attach your MBL drive to a PC and boot from a Linux rescue CD (easily downloaded from the Internet and burned to a CD). You will also need a 4GB or larger USB stick to hold a new OS image and debricking script, and act as a scratch disk for the live CD. While this may sound very complicated it may be your only alternative. I just debricked a DUO a few days ago using this method and I was almost surprised it worked perfectly. I had almost decided to pull the HDDs and toss the DUO.

My advice is to decide if that noise you are hearing is normal for a healthy HDD. Even if not, debricking a broken HDD won’t do any harm and may help. So I think you should start studying how to debrick your MBL.

Banned, you’re absolutely right: without a sniffer like Wireshark you cannot see which packets are on the wire. And without a portscanner like nmap you cannot be sure which ports are in listening mode…
I had contact to WD Support and they agreed with me that a defective firmware might be the cause. I just got the HDD out of the case. I removed the controller and what remains on my desktop is a simple SATA-HD. I will connect it to my PC tomorrow. Then I’ll see what data is still stored.

If your data is not corrupted there should be absolutely NO problem recovering your files… That of course is the first step. Save the data! If that PC program won’t work for you, burn a LInux live CD and boot from that, mount the WD drive and copy it off to a USB drive or whatever. (Some debricking scripts say disconnect your system drive on the PC.

I debricked my DUO last week but I run Debian on my desktop so it was no problema! Actually I picked Debian because (1) my Linux mentor said it was the best for my dedicated server (8,000 miles away!) and I got good at Debian, and then (2) I was blown away when I realized MBL uses Debian! (Too bad they had to muck it up with mixing distros.)

The DUO debricking script works perfect because it saved my 8TB DUO. If there is a similar script for the plain MBL then all you have to do is be patient and follow the instructions. Mostly the difference would be which image you apply to the system partition(s). If somebody wrote that you should be able to debrick your MBL and get up and running again.

The only possible problems are (1) no debricking script, (2) MBL broken, or (3) lost your data but can get it working again. Wheeeee!!! Ain’t we havin’ fun?

I’m a professional hardware/software developer with decades of experience. And… I’m getting much better at Debian internals.