No access to files when off him network, Java error

When I am at home and connected to my home network everything works fine.

Connecting remotly with iphone or Ipad via the WD 2Go app again everythingi fine.

Try to connect via Safari 7.0.5 runnning Java version 7 update 67 I can not access my files. I have tried multiple Java settings and security levels, added URLs to the exception list and the image below is as far as i can get.

I have rollled Java back to earlier versions but still no access what am i missing?

Can somebody please help?

this forum has an issue with images taking days to show up so I can’t see the actual error

what are you trying to connect to?

Local LAN? or remote?

what error are you getting?

there should be a window asking for prmission to continue, it could be under another window. Try minimizing 1 window at a time to try to find it.

it this dosen’t work check the event viewer logs to see if there is anything relevant, sorry i just notice you are on a mac, is there anything similier?

Hi, I am trying to access my files remotely by login in via the mycloud login in page.

When i log in i see both my WD Lan drives which I can select. I then can get past the Java warnings to the MyCloud page where it tells me how many shares I have and a link to “Can’t see your shares?” 

under that in the centre of the page is a java panel with a large Java logo and what looks like a progress bar under it and thats it.

I have perfect access remotley to both my drives on my iPad so I am sure its a Java setting but have no idea what.

Thank you for your assistance so far.