No access to DashBoard with static IP

Hi to all,

when I try to access my 6Tb unit with a dynamic address all it’s ok. I can do everything (configuration, management…).

But if I change the address to a static one, (I need it for many reasons) it becomes impossible to reach the unit.

The message I get is:

Forbidden
You don’t have permission to access /UI on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Note that:

  1. I try to connect to the unit from the same network where it is.
  2. The problem is present with http://xxx.xxx.xxx.xxx and with http://name_of_unit
  3. I can normally login into the unit (with static IP) from a ssh client
  4. The firmware is updated to the latest version

Can you help me?

Thanks in advance,

thibaud

1 Like

Is the My Cloud using the same workgroup name as the computer? The default is usually “Workgroup”.

Have you tried restarting the computer? Have you tried clearing the browser’s cache and disabling any browser extensions (especially ad blocking or script blocking extensions)? Have you tried using a different web browser?

If you haven’t done so already as a troubleshooting step you may want to perform a 4 second reset and see if that clears the issue, if not try a 40 second reset and try again.

https://support.wdc.com/knowledgebase/answer.aspx?ID=13986

Generally it is better to reserve a static IP address for the My Cloud in the router/gateway’s DHCP server rather than setting the static IP through the My cloud Dashboard.

I resetted the unit many times, in order to can login into (with a dynamic address). The procedure works…

Moreover:

the workgroup is the same.
I rebooted the pc;
I tried with many different browsers;
I tried also to connect to the unit from other pc’s in the same network
No ad and script blocking

It seems a problem related to the configuration of the web server.

I need a specified static IP because I am in a corporate network where the addresses are ‘imposed’ and where the dhcp server works in a
different address space.

Thanks again,

thibaud

If the My Cloud is on a corporate network is it possible the corporate network is configured to block HTTP access to devices they don’t approve of or are not supported by corporate IT?

I think if you’re NOT using RFC 1918 addresses, it will throw this error, but I can’t remember if that’s the case or not. I just have a vague memory…

Brenner,

I recently ran into this problem and in case anyone else stumbles on it I’ll paste my response below.

In short, the symptom is thus. After changing to a static ip, the web portal throws 403 forbidden, yet file sharing and ssh still work. By default, the web portal is not accessible to hosts that are not on the same subnet. So assuming that your computer is on the same subnet as the ip settings you uploaded to the mycloud, the problem is that the apache config file might not have gotten updated with the correct local subnet to use. If you have ssh access you can go edit the file. You can access my writeup here. You need to add a line that looks like “Allow ip ip/subnet” where ip can be the static ip you assigned to the mycloud, and subnet is something like /24, or if its easier to think about, 255.255.255.0 without the slash" Save the file and reboot the device. This affects the latest firmware at this time, it might not happen every time, but obviously once this is encountered, if you don’t have ssh enabled you can’t fix it.

edit I tried editing the config file by hand but it looks like it was blown away and replaced by a faulty one.