No access from LibreELEC/Kodi device to "public" shared folder

Hi to all
At my nephew’s house about a month ago I mounted a MCH, connected to the Router via an ethernet cable, creating in the “public” folder a subfolder containing its multimedia library. At the same time, we installed a Raspberry PI3, with the LibreELEC distribution (Kody Krypton 17.4) on board. Even the RPi3 was connected by cable to the router. We were able to quickly configure the library, as the MCH (its “public” part of course) can browse the library folder under WORKGROUP by opening “Windows Sharing (SMB)”. I had also tried the alternative “Add Network Location” method, which plans to insert the IP address of the LAN and the shared folder “public”, and also this method worked great.

Today we tried, having moved the Raspy in the bedroom (by connecting it via HDMI to another TV and connecting to the network via Wi-FI), to connect a Wetek Play2 Media Player, with the same version of LibreELEC / Kodi on board (obviously the specific one for the ARM processor, not for Raspy …).
We configure everything on Kodi, language, network, etc. etc. At the time of going to “catch” the contents from the MCH … no way !!! The “WORKGROUP” node under the “Windows Sharing (SMB)” was desperately empty (on the Raspy appeared the MCH, the Router and the two Windows10 PCs at home …). I then try the “manual” method of “Add network location”, putting the IP address of the MCH, and set the folder name to “public” … but the request was timed out.

For testing purpose, from one of the two Windows 10 PCs I ran the Windows File Explorer and typing 192.168.1xx public … I easily access the folder and see its contents.

The sw (LibreELEC) on the two devices (RPI3 and Wetek Play2) is the same, the network idem. What can be different about accessing the MCH public?
Have I to set a specific username and pwd (I left the two fields blank on Raspy). If yes, which ones? I had read that the MCH accepts up to 5 contemporary Samba connections, so I don’t think that’s the problem either.

Some idea?
thank you in advance


Can you access the Public Share of the My Cloud Home from Windows 10 or any other computer?
My-Cloud-XXXXX/Public is SMB and not password protected to it’s a wide open network share.