NFS help

This is driving me nuts Ive done tons research and tried so much and nothing is working.

I really want to get NFS working

Im using Win7 x64 I set up NFS with haneWIN NFS and connect on my wd tv live on linux share.

It finds ip address of the share and I can see the shared folder but when i try to open it wd tv gets stuck and i have to unplug. Hanes is showing the wdtv as client



There is some sort of communication issue my router shows activity lights. Also for split second i hear the HDD being accessed. Ive disabled all security opened all ports on my router. Port forward 1058, 2049, 111 I read with older wdtv you have to mount is this possible with my gen 3 i cant access threw telnet

well if you figure it out, I’m sure it will help a lot of people

myself, I connect via NFS from ubuntu server with no problems

I tried to set up similiar to your set up for my Dad

win7 64 bit Hanwin

same stuck, once you try to access it

I’ve personally, given up and call this a bug from WD, which needs to be fixed, probably with the kernel

or NFS mount configuration on WD side

also, many of the NFS export options available on a full server are not available in Hanewin

I suspect if possible to get in to telnet

manually mounting the shares, would likely resolve the issue, by trying different mount parameters

but the process to get telnet access on WD SMP is a bit to involved to post on these forums

if you’ve got the skills you’ll be able to find the info and implement it yourself

so if anybody else has idea’s, I’d love to hear them as well

Yea i was trying telnet but connection refused.

I asked about telnet becasue i read about it with older models but they have an option when accessing local settings.

This SMP dont so IDK I have another drive and ubuntu ill probably give that a try.

Windows share really isn’t a problem my 1080 mkv stream fine but was curious how much faster nfs would be

OMG i figured it out.

i had a stutter issue with movie i checked bitrate would reach almost 97455 kbps and under network usage it was inconsistant

so i was researching and someone mentioned changing jumbo packet on my network card in device manager

to highes avaible.

I set it back to lowest and i can acess NFS share no problem.

Another thing i noticed i still got some stuttering on that move bigh bitrate point so i set

speed duplex from auto to 1000Mbps full and still got stutter

I tried 100Mbps full and no stuttering.

I have a gigabit router (cisco rvs4000) and WD only 100Mbps but didnt think would impack perforamce but it did;/

I only have 65/11 internet and wd live so setting to 100 has no impack so ill just leave it im happy.

before on SMB

Now on NFS and no the stutter went away


I’ve seen this crop up before, on the same movie, Prometheus, where I demonstrated that the rip itself was bad, as NO bluray movie should EVER exceed ~40 megabits per second.

Your bitrate report shows identical behavior to the other poster.

I wonder if ya’ll downloaded the same pirated rip.   :wink:

glad it’s working for you,

unfortunately for my dad, I’ve already been through the jumbo frame settings and quite a few other things as well

Jumbo frames == NONSENSE in most cases.

People who recommend it usually have no idea what problems it can create.

SHORT SUMMARY:   Do *NOT* enable Jumbo Frames — EVER – unless you can enable matching MTU parameters on *EVERY* device in your network.


I wouldn’t say Never, there is a time a place for Jumbo Frames

but yes, I know all about the problems it can cause

and in most cases (95+%)

it’s completely useless and not worth the hassel

That’s why it’s one of the first things I disabled on his network

You also changed something else:

I tried 100Mbps full and no stuttering.

Where did you set that?

Thats me no wonder why my password didnt work forgot username and made new profile.

my mind is a blur trying to figure this NFS thing out

when you say bad rip do you mean highly compressed? becasue i though i read that the higher you compress the higher the bitrate will go

i set to 100 full duplex . Go to your nic in device manager


demo23019 wrote:


i set to 100 full duplex . Go to your nic in device manager 

Remember when you do that, you have to change the other end of the link, too…  or lots of network errors will result.

what do you mean change other end of link?

Any time you change the Speed / Duplex to MANUAL instead of automatic, you MUST configure the other end of the link as well.

If you set the PC to 100/FULL, then the switch (or whatever it’s plugged into) must be configured to match.

Otherwise, it will still be set to auto negotation, and will go to HALF DUPLEX mode. 

Having duplex mismatched at each end of the link will cause many network errors.

Oh ok i didnt know that my network knowledge is pretty basic.

Thanks for heads up i went on router and ports were set to automatic. they are now set to 100 full

I know old thread, but earlier I commented, that I counted this out as a WD bug

I guess, I’ll need to amend my statement

I put a new NIC in my Dad’s PC

and what do you know NFS now works

non-working nic used a realtek chip

working nic uses an intel chip

that’s about the only difference I can tell, nic settings are identical

since the realtek, is on mobo

a simple test

moving the cable between the 2 and a reboot, realtek no work, intel nic works