NFS and WD TV Live SMP

Hello!

I try to create a NFS Server on Win7 x64 with the tool “NFS Server” (link below), but somehow the WD TV Live SMP (gen3) does not show the NFS Linux share. Theoretical it should work but i don’t get it work…

Can someone please confirm that this should work or will never work? Is it even possible to connect the WD TV Live SMP with a Windows NFS share? Is “Linux Share” and NFS even the same thing?

The problem is that the WD TV Live SMP does not like my Speedport 921. The router have a Samba server (the advert says:NAS-functionality) and is accessible from the PC and the DLNA service does also work well on the WD TV Live SMP, but the SMP does not connect to the router network share! (it does not show the router name)
So i try to “reroute” the files from the router netshare through a NFS (Linux Share).

I want to have the Mediadata (thumbnail pictures) wich are apparently not showing from the DLNA source. :frowning:

Can someone please help me to build up a proper working NFS Server on windows, please.
Because this would be the most convenient solution in the current state. Thanks.

Setup:
PC -> (Lan) Speedport 921 (HD connected to router) -> (WLAN) WD TV Live SMP
Link:
http://www.hanewin.de/nfs-d.htm (the tool contains also a english translation)

bye

PS: I already found out that “rerouting” a windows share seems to be impossible :frowning:

Yes, Linux Share means NFS share.

I have tested a lot this day and got the NSF server working now.

I can mount local directorys and see them in the SMP now, but when i try to mount the net share from my router it is not accepted in the box.

The direcotry name from the net share is shown in the WDTVLIVE SMP. This happens to both, trying “\SPEEDPORT.IP\MediaDisc” and the drive letter “Z:”

When i try to open the NSF folder the SMP respons with an error massage:

"There is no media in the current folder"

 

 

The NSF netshare seems to work, but the WD mediaplayer disappoints again with its network compatibility … :frowning:

 

The rest of the player is superb, i love the support of h.264 L5.0 and other things. But how good is it if you cant connect it to your network? o0

 

I hope WD fix the compatibility to the Speedport 921 soon!!! pls

The Speedport is shown as “Windows 2000 Professional” while the WDTVLIVE is shown as  “Windows NT 4.9 Server” maybe a version conflict or whatever?

 

PS: solution the get the NSF Server working on Win7 x64 is: to use the 32bit files. The 64 bit binarys seems to be bugged. And of course also some firewall settings.

I don’t understand what you’re trying to do.  You keep speaking of NFS, but giving examples that are NOT NFS, they are Samba.

seems you dont understand the difference between NFS and Samba. That network stuff was new to me one week ago, too. :wink:

NFS is a unix based network transfere protocoll, samba is another transfere protocoll, used by Windows for the “Folder Share system”.

What i tried to do?

because i didnt got any conection on the “Share” page on the SMP, i tried to get my media files to the SMP thought the NFS protocoll, what didnt worked! (see previous post)

HD on router->router samba:\ -> PC - router netfolder share -> NFS server -> SMP -> Linux Share

Seems the SMP have a very bugged network part, because it just dont want to connect to any share on my network!

(other devices and PCs have no problem)

After a week of bughunting i am sick and tired of this darn box and ready to burn it in a big fire explosion. :frowning:

Final solution to access iMac (Mountain Lion) shared drive through WD Live TV “Files”.

After reading all those posts and struggling with SMB, SMBup and so on (does not work, donated 1USD regardless), I came to a final solution which worked.

  1. On WD: Enable Linux Shares from Setup menu of your WD TV Live.

  2. On MAC: Forget creating your own exports file, did not work for me, never got the path right. Instead, download NFS Enabler from http://support.firecore.com/entries/20631337-streaming-from-mac-os-x-10-7-lion-mountain-lion. This one has GUI and does it right.

  3. VERY IMPORTANT: on your mac, go to finder, select the folder you want to share (in my case Movies), right click, Get Info, check that folder is Shared tick box is on, and most importantly, add Everyone to shared user list. Click on the lock, enter your password, add Everyone. This is the secret that worked for me.

  4. On WD Live TV: go to Files -> Content Sources->Network Shares->Linux Shares. It will scan the network and your MAC’s IP will appear. Can take up to 30 seconds.

  5. Enjoy.

I am not saying this is universal - this is what worked for me. Two main things - first, NFS Enabler which does this exports thing right, second - add everyone to shared folder users, otherwise the folder will come up empty - it will say you have no access. I did not figure out where to enter user name and password for Linux share. 

Hope this helps. Posting this as a thank you for all people who guided me today. 

By the way, I needed network share access only because of SRT support, which PLEX media server does not provide. If you don’t need subtitles or any other specific reason to access your Mac through network share, just install Plex Media Server on your and run everything through DLNA, saving yourself from all this bull**bleep** with Linux shares and export files (shudder).

Took me while but figured it out not sure if this will help

If your are on a homegroup go to network settings on WD TV Live SMP and set workgroup to homegroup

As for haneswin nfs i use default settings and mount share

Untitled.png